Results 1 to 3 of 3

Thread: Mail and pop3 errors on new install

  1. #1
    Join Date
    Aug 2003
    Location
    The South
    Posts
    137

    Mail and pop3 errors on new install

    Just setup a new server last night, everything seems ok except welcome emails aren't being sent so a little investigation yields:

    [root@www9 log]# mail -s "TEST" gary@8-95.com
    asdf
    .
    Cc:
    /usr/sbin/sendmail: No such file or directory

    ok fine looked at my other box, that file belongs to da_exim so I did a rpm -Uvh --force da_exim(blah).rpm

    No luck, so I checked maillog and I see loads of these:
    Oct 1 20:22:01 www9 vm-pop3d[18927]: Quitting on signal: 15
    Oct 1 20:22:01 www9 vm-pop3d[18926]: Quitting on signal: 15
    Oct 1 20:22:01 www9 vm-pop3d[18925]: Quitting on signal: 15
    Oct 1 20:22:01 www9 vm-pop3d[18924]: Quitting on signal: 15

    Any clues on this?

  2. #2
    Hello,

    For the sendmail not existing, try
    Code:
    cd /usr/sbin
    ln -s exim sendmail
    For the signal 15, I went browsing throught vm-pop3d source code and found:
    #define ERR_LOCK_FAILED 15

    which is probably saying that it can't get a lock on the mbox file, so it's giving up (might be in use). Check for lock files in:

    /var/spool/mail/*.lock
    /var/spool/virtual/*/*.lock

    delete them if they exist (some might be valid but should only stay for a few seconds)

    John

  3. #3
    Join Date
    Aug 2003
    Location
    The South
    Posts
    137
    I did the ln already for the sendmail not exist problem seemed to fix that, I "think" the vmpop errors mighta been restarts.

    Originally posted by DirectAdmin Support
    Hello,

    For the sendmail not existing, try
    Code:
    cd /usr/sbin
    ln -s exim sendmail
    For the signal 15, I went browsing throught vm-pop3d source code and found:
    #define ERR_LOCK_FAILED 15

    which is probably saying that it can't get a lock on the mbox file, so it's giving up (might be in use). Check for lock files in:

    /var/spool/mail/*.lock
    /var/spool/virtual/*/*.lock

    delete them if they exist (some might be valid but should only stay for a few seconds)

    John

Similar Threads

  1. E-mail forwarding and pop3 e-mail account question
    By TheDon in forum User-Level Difficulties
    Replies: 5
    Last Post: 07-04-2006, 11:59 PM
  2. Stunnel pop3 imap smtp errors
    By chiptecmm.com in forum System-Level Technical Discussion
    Replies: 4
    Last Post: 06-26-2005, 03:09 PM
  3. Errors after install
    By coold8 in forum Installation / System Requirements
    Replies: 0
    Last Post: 07-24-2004, 07:00 PM
  4. install.sh errors
    By thehostworks in forum General Technical Discussion & Troubleshooting
    Replies: 1
    Last Post: 05-30-2003, 02:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •