PDA

View Full Version : changing default user folder



itman21
01-03-2004, 07:14 PM
Hi, Anybody done changing DA's default user folder to another location ? I believe it is now

/home/user_folder

For example to another location like :

/home/tomcat4/webapps/folder/users/user_folder

I am trying to use DA with a Java Application that sits inside /home/tomcat4/webapps/application/

Any feedback would be appreciated.

Sun Joo

ProWebUK
01-03-2004, 07:21 PM
You would have to chnage the paths in the users httpd.conf

Chris

itman21
01-03-2004, 07:58 PM
Thanks :) for your advice. Is it just like that ? I mean is that all I need to change ? Then, all user folders are created at
/home/tomcat4/webapps/application/users/user1, user2, usern, etc. ??

Also, I would not have problems with common requirements such as cgi, php, perl, etc. supports ?

Cheers,

Sun Joo

DirectAdmin Support
01-03-2004, 10:43 PM
Hello,

Actually, it's quite easy to change where RedHat puts the users when they're created. Just edit

/etc/defaults/useradd

and change HOME= to

HOME=/home/tomcat4/webapps/application/users

Then all users you create will (should) be created there. There is no hardcoded reference to /home/username, and DA always asks the system where the home directory is. No modifications to any other files would be required.

John

itman21
01-04-2004, 05:47 PM
Thank you John. I tried it and it worked just beautiful ! Trust this new folder is compatible with all DA functions, without causing problems ???

Thanks again and others I requested are all working fine now. Thanks again.

DirectAdmin Support
01-05-2004, 12:08 PM
Hello,

DirectAdmin retrieves the home path from the system and doesn't *assume* that it's in /home, although it is in the /home path 98% of the time :) . I can't forsee anything that wont work at the moment, you can just test it out if you want to be sure.

John

S2S-Robert
01-05-2004, 04:42 PM
this gets me thinking about another possibility, if I were to add an additional hard drive and mount the entire harddrive as say "/home2" and change useradd like you said to use /home2, this would enable new users to be created on the new hard drive is that correct? And apache / vhosts would just automatically know that they should go to /home2 instead of /home right?

DirectAdmin Support
01-06-2004, 09:12 AM
Hello,

Yes, you bet :)

John

itman21
02-01-2004, 04:17 PM
Hi John, Thanks for the help always.

During DA installation, I used default folder /home/admin

But later I changed default folder as in above note. Now, I wonder if you could advice me on how :

1) can I change admin folder to /home/tomcat/webapps/.. from /home/admin ? It seems it will not do it even if I changed hpttd.conf mannually.

2) change default folder, for example "user6" account.
a) from :
/home/tomcat/webapps/xelpa/users/user6/domains/user6.broadbandcms.com/public_html

b) to: /home/tomcat/webapps/xelpa/users/user6

My feeling is not easy and perhaps will affect other settings as well....

Thanks.

Sun Joo

DirectAdmin Support
02-02-2004, 10:02 AM
Hello,

1) make sure the home paths have been correctly updated in the /etc/passwd file. (I think you've done that) If not, use the "usermod -d /new/path/to/home username" command.

2) run:
echo "action=rewrite&value=httpd" >> /usr/local/directadmin/data/task.queueJohn

itman21
02-02-2004, 03:41 PM
Thanks... I typed it and it just returned the next command prompt..

I think I should get some kind of option to change the folder path value ??

1) is okay as per your instruction

2) still not clear.

Cheers

Sun Joo

DirectAdmin Support
02-02-2004, 11:26 PM
Hello,

#2 just adds one line to the task.queue file. It won't give you any output and will just return to the command prompt like you said. Every minute, the dataskq program runs, check that file for contents, and if there is something in it, it will run it. The command just rewrites httpd.conf files.. nothing more. I'm assuming you've changed the home directory for some users, so the rewrite will redirect the public_html folder to the new location automatically.

John

Nutz
03-20-2006, 08:59 AM
I used this method to add a new user on another hd but now I have a problem. DA no longer sends my welcome emails with connection info, and I can not connect to the new user webspace using the

http://ipaddress/~uname method. This still works for the accounts on the other hd.

Actually logging onto the user from the ACP produces errors when trying to do anything as well. Things like you do not own that domain etc etc.

Fedora core 1 on this box.

--Thanks for any help