PDA

View Full Version : Problems with three services



josetann
01-13-2004, 01:31 PM
Again, I'm using FreeBSD 5.2, so some of these problems may be tied to that.

First, I had the same problem with mysqld not starting, until I added the "cd /usr/local/mysql" line in the startup file.

Second, when trying to start exim I got this:

datest# /usr/local/etc/rc.d/exim start
Starting exim: /usr/libexec/ld-elf.so.1: [ OK ]
Shared object "libutil.so.3" not found

Did some researching, and FreeBSD 5.1 comes with libutil.so.3, while 5.2 comes with libutil.so.4. I fixed it by creating a symlink like so: ln -s /lib/libutil.so.4 /lib/libutil.so.3

Lastly, ProFTPD wouldn't work either. After fixing the first two I noticed it was now working. I deleted the symlink created above and it gave the same error. So both it and exim were looking for /lib/libutil.so.3.

rhoekman
01-13-2004, 08:43 PM
The compiler toolchain is now based on GCC 3.3.X, rather than GCC 2.95.X. I wonder if this is related to it. Did you do a CVSup and make world and install? (Probably)

josetann
01-14-2004, 12:20 AM
I just did a fresh install of FreeBSD 5.2. I forget everything I chose, but I think I did the user install with binaries (something like that). Installing DA was actually pretty painless, but a few things (such as these services not starting) did pop up.

The only thing I installed separately, was I chose vi lite via sysinstall, and installed the pico editor from ports. Otherwise it was just a generic, clean install.

rhoekman
01-14-2004, 12:31 AM
Maybe Exim is prebuild by DA against the old compiler?

DirectAdmin Support
01-14-2004, 09:27 AM
Hello,

All FreeBSD binaries are being compiled on 5.1, so if 5.2 changed anything, they'll probably break.. I think they've changed libutil versions, so what I'll do is recompile them as static, so that they don't have any dependancy on any libraries at all.

John

GARMTECH
01-29-2004, 12:15 PM
The best solution I know is to install FreeBSD 3.x (or 4.X) binary compatibility from Distributions.