PDA

View Full Version : Huge dovecot problems



ZPillay
02-13-2007, 11:55 AM
Dear DA users, i've been working on this problem for about a week now, can't seem to solve it.

My mailserver (dovecot) is not responding.
I cannot receive any emails on any account.

Dnsreport gives everything OK on my domains, except mail which gives:

Mail FAIL Connect to mail servers ERROR: I could not complete a connection to any of your mailservers!

XXXXX: Could not connect without glue or A record.

If this is a timeout problem, note that the DNS report only waits about 40 seconds for responses, so your mail *may* work fine in this case but you will need to use testing tools specifically designed for such situations to be certain.

I tried the following things:
1. Dovecot updated to latest version, no difference.
2. Telnetting to dovecot (port 25), it just disconnects me without any message, i cannot even enter HELO.
3. Changing MX record (mail.domain.org and domain.org, kept moving them around but then i realised it is not dns related).

I am kind of lost in this issue. None of my domains on that server work.
Is there a way to fix this easily?
P.s. Logs in the /home/username/Maildir (if i remember correct) are encoded or smth, it cannot read it using vi (the usual text editor).

Thanks in advance,

Exim works fine, sending mails works fine

Marshall
02-13-2007, 12:16 PM
Dovecot is not what it is talking about, the mailserver it is trying to connect to is Exim. Try restarting exim with "service exim restart" in a ssh shell and see if it reports any errors and check the exim logs since dovecot only delivers the mail to the mailbox locally, Exim is what is actually connected to by outside hosts to send the email to you.

ZPillay
02-13-2007, 12:26 PM
Thanks for clearing that up, however exim restarts fine (i've tried that before) and there are no errors in its logs.
The sent emails (to the accounts on the server) don't even appear in the logs, only the sent emails (from the accounts on the server) are in the logs :S

Marshall
02-13-2007, 12:50 PM
Do you have any kind of firewall in place that might be blocking port 25 inbound? Or possibly even your hosts.deny file?

ZPillay
02-13-2007, 01:35 PM
I have APF + BFD installed, however i've kept switching it off (to make sure that its not influencing it)

Port 25 is allowed inbound, outbound, tcp and udp (once again just to make sure ;)) on the firewall rules

Found the problem, it lied within iptables + apf installation. Something is blocking the port. Once i disable IPTables, it suddenly works :S
Need to find out now how the heck the APF rules are not implemented in IPTables *sigh*

Thanks for the help Marshall!