PDA

View Full Version : How to undo this?



FinLy
07-18-2007, 05:38 AM
Hello,
May I know how to undo this custombuild?
I mean, I have done all the steps, in http://files.directadmin.com/services/custombuild/beta/
, but I want to back to the state before I did it

Thank you

floyd
07-18-2007, 07:23 AM
You have not told us what you did. Custombuild can do a lot of things. What do you want to undo?

FinLy
07-18-2007, 09:26 AM
Hello,

Thanks for your reply.
What I have done is what written in the site:

cd /usr/local/directadmin
wget http://files.directadmin.com/services/custombuild/beta/custombuild.tar.gz
tar xvzf custombuild.tar.gz
cd custombuild
./build update_data
./build all d

I can't get it work. My apache stop and I got error message :
Syntax error on line 30 of /usr/local/directadmin/data/users/thekong/httpd.conf:
Invalid command 'php_admin_flag', perhaps misspelled or defined by a module not included in the server configuration

I want to undo all what I have done.

Randy
07-18-2007, 09:49 AM
First try to uncomment line 30 in your httpd.conf and start apache. Does it work than?
Also read this (http://www.directadmin.com/forum/showthread.php?t=19221&page=3). (Love the search function)

smtalk
07-18-2007, 09:56 AM
FinLy, http://www.directadmin.com/forum/showpost.php?p=104525&postcount=1 - look at the last question - 14.

FinLy
07-18-2007, 10:31 AM
Thanks for the answers, Friends.
But, that error message still appears...

Also, I got this when build it:
cd . && /bin/sh /usr/local/directadmin/custombuild/gd-2.0.35/config/missing --run automake-1.9 --foreign
cd . && /bin/sh /usr/local/directadmin/custombuild/gd-2.0.35/config/missing --run autoconf
configure.ac:64: error: possibly undefined macro: AM_ICONV
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
make: *** [configure] Error 1

smtalk
07-18-2007, 10:40 AM
Because queue isn't executed yet :) Do:


/usr/local/directadmin/dataskq
service httpd restart


For GD:


./build update
./build iconv
./build autoconf
./build automake
./build gd

FinLy
07-18-2007, 11:06 AM
Hello Martynas,

Thank you very much for your answer. GD is done now.
But the php_admin_flag problem still can't be fixed.




[root@server custombuild]# echo "action=rewrite&value=httpd" >> /usr/local/directadmin/data/task.queue
[root@server custombuild]# /usr/local/directadmin/dataskq
[root@server custombuild]# service httpd restart
Stopping httpd: [FAILED]
Starting httpd: Syntax error on line 30 of /usr/local/directadmin/data/users/finly/httpd.conf:
Invalid command 'php_admin_flag', perhaps misspelled or defined by a module not included in the server configuration
[FAILED]

smtalk
07-18-2007, 11:10 AM
Hmh, what version of DirectAdmin are you using? Do you have anything in /usr/local/directadmin/data/templates/custom? If yes - do:


rm -rf /usr/local/directadmin/data/templates/custom/virtual*


And then do this again:

echo "action=rewrite&value=httpd" >> /usr/local/directadmin/data/task.queue
/usr/local/directadmin/dataskq
service httpd restart

FinLy
07-18-2007, 11:14 AM
Hello Martynas,

Thank you for your reply. I am using DA v.1.30.1.
And I have nothing in /usr/local/directadmin/data/templates/custom
I tried custom build on fresh server with new DA

smtalk
07-18-2007, 11:18 AM
Okay, try this:


./build rewrite_confs
service httpd restart


If it doesn't help - please contact me on instant messenger and it will be fixed for free.

FinLy
07-18-2007, 11:26 AM
Hello Martynas,

Thank you very much for your fast and kind responses. I appreciate it so much.
I did the step, but gives me other error messages now.

What instant messenger you are using now?

Thank you

smtalk
07-18-2007, 11:44 AM
I'm on MSN, ICQ and Skype now :) What error do you get now?

FinLy
07-18-2007, 11:48 AM
I just sent you PM.

Here is the error:
Syntax error on line 17 of /etc/httpd/conf/httpd.conf: Cannot load /usr/lib/apache/libphp5.so into server: /usr/lib/apache/libphp5.so: cannot open shared object file: No such file or directory

FinLy
07-19-2007, 06:25 AM
Smtalk, helped me fixed the problem.
Thank you very much, Martynas. You are the Man!!

Cybex
08-08-2007, 05:17 AM
What was the solution? I have the some problem and I am stuck with the last error message you have also:


Starting httpd: httpd: Syntax error on line 17 of /etc/httpd/conf/httpd.conf: API module structure `php5_module' in file /usr/lib/apache/libphp5.so is garbled - perhaps this is not an Apache module DSO?


UPDATE: I think I need to update PHP5. Trying that now...

UPDATE2: Reinstalling PHP5 solved my problem