PDA

View Full Version : ./build zend error



rhoekman
02-11-2004, 10:54 AM
tester# ./build zend
File already exists: ZendOptimizer-2.1.0b-FreeBSD4.0-i386.tar.gz

Location of php.ini:
/usr/local/lib
Press return to continue...

/usr/libexec/ld-elf.so.1: Shared object "libc.so.4" not found
tester#

Zend is not active if you install it on 5.x ? I see the binaries but it is not active? Also I have tried to get the 4.x compatible binaries installed no luck yet..

DirectAdmin Support
02-11-2004, 11:10 AM
Hello,

They only have the FreeBSD 4.0 binaries... might be out of luck. Or you could just try find libc.so.4, or even just create a symlink (symlink might not work).

John

rhoekman
02-11-2004, 11:33 AM
This is pretty nasty because most of the billing/autosignup software are using zend.. I have to hunt for Ioncube enabled ones then.. Darn I just bought whoiscart :(

existenz
02-18-2004, 09:40 PM
Ok here is what I have come up with. You can install:

/usr/ports/misc/compat4x

I got the default zend to work. The problem is I could not verify the entire install, when it asked where my php.ini file was I put where I thought it was and it was not their. In the process of checking apache stopped working. I can't verify it works but I am almost positive it should work on 5.x with that.

DirectAdmin Support
02-19-2004, 09:16 AM
/usr/local/lib/php.ini

I think the apache check works but their interface forgets to update itself.. i think you can just click enter... and it will continue.

John

existenz
02-19-2004, 12:45 PM
Ya my fresh install of FBSD 5.2.1-RC2 & DA 1.21 does not have the php.ini file there. I was looking to see if it got installed somewhere else.

DirectAdmin Support
02-20-2004, 08:55 AM
Hello,

That's a bit odd.. the build script should copy it over.

From the php-4.3.4 directory, it runs this

echo "Copying php.ini..";
if [ ! -e $PHP_INI ]
then
cp ./php.ini-dist $PHP_INI;
else
echo "$PHP_INI already exists, skipping.";
fi
I wonder if the /usr/local/lib directory didn't exist? not sure what would prevent root from copying the file.

John

rhoekman
02-20-2004, 11:22 AM
Since I started this thread I'll setup a 5.2 box again (with SCHED_ULE compiled on a dual xeon! wheeee!) I switched to 4.9 to get things running with formentioned whois.cart.. So that's why I'm not posting and testing at moment.. I get things up and running this weekend..

existenz
02-20-2004, 11:26 AM
John,

Just so you know the /usr/local/lib was installed and contains the following:


compat libgd.a libintl.a
libasprintf.a libgd.so libintl.so
libasprintf.so libgd.so.4 libintl.so.6
libasprintf.so.0 libgettextlib-0.13.1.so libjpeg.a
libcharset.a libgettextlib.so libjpeg.so
libcharset.so libgettextpo.a libjpeg.so.9
libcharset.so.1 libgettextpo.so libpng.a
libexpat.a libgettextpo.so.1 libpng.so
libexpat.so libgettextsrc-0.13.1.so libpng.so.5
libexpat.so.4 libgettextsrc.so liby.a
libfreetype.a libiconv.a m3
libfreetype.so libiconv.so perl5
libfreetype.so.9 libiconv.so.3

Is their a DA installer log? That should shead some light...

existenz
02-20-2004, 10:04 PM
Sorry about this spreading across a few threads but since I did a ./build clean & ./build all Apache worked. After I installed compact4x from ports Zend worked perfectly.

phpinfo shows me that Zend is installed on my 5.2.1-RC2 box...

rhoekman
02-21-2004, 11:26 PM
So how do we incorporate this into the installer.. As far as I can tell there is no Binary yet of compat4x if you want it installed the way DA does with pkg_add -r .. I think it is a bit tricky to Beta test this thing on a 5.x release candidate. At moment it is in still in development yet so all these little quirks might be solved when they release the production version and we can do some proper testing.. I do not say stop testing though :D