PDA

View Full Version : phpMyAdmin 2.11.0 is released



smtalk
08-21-2007, 03:39 PM
Announcement
------------

The phpMyAdmin Project is proud to announce the immediate availability
of phpMyAdmin 2.11.0, which will probably be the last series supporting
PHP 4.

This version supports creating VIEWs from query results
and can manage triggers, procedures and functions. It also supports
MySQL 5.0.37 query profiling and has an improved interface for servers
hosting thousands of databases and tables.

phpMyAdmin is a web administration tool for MySQL databases, intended to
handle a whole database server as well as a single database. Over the
years, it has become the most popular Web GUI for MySQL.


Improvements
------------


+ [import] support handling of DELIMITER to mimic mysql CLI,
thanks to fb1
+ improved PHP 6 compatibility
+ [core] added PMA_fatalError() and made use of it
+ [doc] changed all documentation in config.inc.php
to phpDocumentor style
+ [data] support for CREATE VIEW from query results
+ [gui] dropped css/ folder and moved into root of PMA
+ [l10n] new: Sinhala, Macedonian
+ [export] YAML export (see yaml.org), thanks to Bryce Thornton
+ [upload] moved file upload functionality into own class
+ [upload] make use of cfg['TempDir'] for file uploads
+ [server] improved display of binary logs
+ [data] better error handling in tbl_create.php
+ [routines] from Patch #1649881, thanks to Mike Beck
+ [querywindow] store sql history in session
+ [querywindow] sql history now without db too
+ [querywindow] tweaks in sql history view
+ [export] Native Excel (Spreadsheet_Excel_Writer) improvements,
thanks to Christian Schmidt
+ [doc] requirement of mcrypt on 64-bit, thanks to Isaac Bennetch
+ RFE #1435922 [gui] navigation frame shows listing of databases
when none selected
+ [data] support BIT datatype (under mysqli),
thanks to Christian Schmidt
+ [display] automatic confirmation for sort by key,
thanks to Juergen Wind
+ [data] can now choose the number of insert rows
+ RFE #1704779 [gui] link documentation from login page
+ RFE #1513345 [setup] check control user connection during setup
+ [structure] TRIGGERS: display/edit/drop/SQL export
+ [browse] store browse state in session per query
+ [gui] Insert/Edit: no longer display the Go button each 15 lines
but just at the end of a row
+ [gui] Query window: use verbose server name if any
+ [auth] patch #1712514 specify host for single signon,
thanks to Thierry
+ [gui] Navigator for the db list in the navigation panel
+ [gui] Navigator for the table list in the content panel
+ [display] Support for MySQL 5.0.37 profiling
+ RFE #1743983 [gui] Replace max_characters by a configurable param:
cfg['MaxCharactersInDisplayedSQL']
+ [display] patch #1749705, Allow multibyte characters in number
formatting, thanks to garas
+ [privileges] Support password hashing on the Edit Privileges
interface
+ [gui] Export: Select All/Unselect All over the choices,
thanks to Florian Schmitz

Duboux
08-21-2007, 04:00 PM
How to update:

# vi /usr/local/directadmin/scripts/phpMyAdmin.sh
change the line containing:
VER=
to:
VER=2.11.0-all-languages
(how to use VI: type i to insert text, and make your changes, then press ESC and type :wq to save and exit)

Then run the update script:

# /usr/local/directadmin/scripts/phpMyAdmin.sh

smtalk
08-21-2007, 04:03 PM
Or just run this with custombuild:


./build update
./build phpmyadmin

Nivko
08-22-2007, 08:50 AM
Or just run this with custombuild:


./build update
./build phpmyadmin


Updated with succes! :)

DA_user
08-22-2007, 03:34 PM
How do I run this script?

./build update
./build phpmyadmin

??

smtalk
08-22-2007, 03:47 PM
Do this in ssh (if you use CustomBuild):


cd /usr/local/directadmin/custombuild


And execute that commands :)

jw00dy
08-22-2007, 09:41 PM
./build phpmyadmin isn't even an option for me?

and yes I updated the build script. I just used Wael's script which worked fine.

mattb
08-22-2007, 10:58 PM
Just used the

/usr/local/directadmin/scripts/phpMyAdmin.sh

and worked a treat.

smtalk
08-23-2007, 03:18 AM
jw00dy, do you use the latest version of custombuild (1.1.2)? If yes, phpMyAdmin should be there.

jw00dy
08-23-2007, 12:39 PM
??? How do I know what version I have of custombuild?

smtalk
08-23-2007, 12:44 PM
Just write "./build" and you'll see "Version" in the header.

IMcomGuy
08-23-2007, 10:26 PM
Boooooo for phpMyAdmin nixing the dropdown menu functionality by default.

jw00dy
08-24-2007, 07:15 PM
Just write "./build" and you'll see "Version" in the header.
I don't see a version at all.

Here is what I do see.

[root@srv1 customapache]# ./build
*************************************
* *
* DirectAdmin WebServices Installer *
* *
*************************************

To build everything run:
./build all

Other options:
./build php
./build apache_mod_ssl
./build gd
./build libjpeg
./build libpng
./build zlib
./build curl
./build mcrypt
./build mhash
./build zzip
./build mod_perl
./build mod_frontpage #dso depreciated
./build frontpage_ext
./build webalizer
./build zend (not included with 'all')

Apache 2 options (beta):
./build update_data_ap2
./build convert
./build apache_2
./build php_ap2
./build mod_frontpage_ap2
./build mod_perl_ap2

Dovecot options (beta):
./build update_dovecot
./build dovecot
./build todovecot

Remove old build data:
./build clean


Get lastest build script and data
./build update

Get data for current build script
./build update_data

You can pass a 2nd argument to automate the input
./build <option1> d : do the default action
./build <option1> y : answer yes to all questions
./build <optino1> n : answer no to all questions

smtalk
08-25-2007, 02:40 AM
That's customapache, and not custombuild :)

jw00dy
08-25-2007, 01:21 PM
DOH!

I don't have a custombuild dir. :(

Nivko
08-25-2007, 01:24 PM
You can easly install it:

http://www.directadmin.com/forum/showthread.php?t=19221

;)

jw00dy
08-26-2007, 06:00 AM
Thank you!

aleto
08-26-2007, 05:29 PM
When is the update coming out for wael's update script? Its still displayin that 2.10.3 is the latest version...

EGS
08-26-2007, 07:01 PM
How do I see what version of phpMyAdmin I have in DirectAdmin? I can see the following through system information:

Apache 1.3.37 Running
DirectAdmin 1.30.2 Running
Exim 4.67 Running
MySQL 5.0.41 Running

EGS
08-26-2007, 07:21 PM
Ah I see I am running phpMyAdmin - v2.10.3.
Should I upgrade to 2.11.0? If so, why? I am running, as you can see, PHP 5.0.41 :)

agnivo007
08-26-2007, 11:32 PM
Updated to PMA 2.11.0 via custombuild script.
But I get a notice in PMA :

Your PHP MySQL library version 4.1.21 differs from your MySQL server version 5.0.45. This may cause unpredictable behavior.

How to get past this ?
Thanks

agnivo007
08-29-2007, 09:52 PM
Anyone, please?? Any suggestion?

jw00dy
08-29-2007, 11:19 PM
You need to update mysql-client to the current version.

You want:

MySQL-devel-5.0.45-0
MySQL-server-5.0.45-0
MySQL-shared-5.0.45-0
MySQL-client-5.0.45-0

From smtalk on a previous post ** Note for RedHat based systems.

mkdir mysql
cd mysql
wget http://files.directadmin.com/services/all/mysql/MySQL-client-5.0.45-0.i386.rpm
wget http://files.directadmin.com/services/all/mysql/MySQL-devel-5.0.45-0.i386.rpm
wget http://files.directadmin.com/services/all/mysql/MySQL-server-5.0.45-0.i386.rpm
wget http://files.directadmin.com/services/all/mysql/MySQL-shared-5.0.45-0.i386.rpm
rpm -Uvh MySQL-*-5.0.45-0.i386.rpm
/etc/rc.d/init.d/mysqld restart

I personally would run a the following to find out what you have installed, then if you only need to update the client, then only download the client, and install it.

# rpm -qa |grep MySQL

You will probably get the following returned.

MySQL-devel-5.0.45-0
MySQL-server-5.0.45-0
MySQL-shared-5.0.45-0
MySQL-client-4.x.x-x

In which case you only need to download and install the client. If you have more than needs updating, do them as well.

smtalk
08-30-2007, 06:08 AM
No, that's not because of MySQL :) You need to recompile PHP after MySQL upgrade (PHP needs to "catch" the MySQL version change). So, just run "./build php n" with custombuild. Good luck!

jw00dy
08-30-2007, 06:20 PM
Ahh yeah. Well, that's true as long as the client got updated as well :) ;)

Paulius
08-30-2007, 08:10 PM
Ah I see I am running phpMyAdmin - v2.10.3.
Should I upgrade to 2.11.0? If so, why? I am running, as you can see, PHP 5.0.41 :)
Bug fixes, security fixes and (sometimes) new features.

This page lists what they've changed from version to version: http://www.phpmyadmin.net/ChangeLog.txt

agnivo007
08-31-2007, 08:14 PM
No, that's not because of MySQL :) You need to recompile PHP after MySQL upgrade (PHP needs to "catch" the MySQL version change). So, just run "./build php n" with custombuild. Good luck!


Yes, fixed. Should have looked at the FAQ. ;)