PDA

View Full Version : Webmail/SquirrelMail problem



PhilipL
08-27-2007, 02:37 PM
Hi,

after using custombuild to install Apache 2.2 and PHP 4 & 5 (CGI) I cant get squirrelmail and & webmail to work anymore.

Webmail spits out the error:
ERROR (512): Smarty error: problem creating directory "tmp/_cached_templates" (/var/www/html/webmail/smarty/Smarty.class.php:589)

SquirrelMail spits out the error after login:
Error opening ../data/default_pref
Default preference file not found or not readable!
Please contact your system administrator and report this error

I've looked on the forums and read about using ./webmail.sh and ./squirrelmail.sh to fix the permissions but this hasn't worked.

Anybody else have any suggestions please?

Thanks for the help,
Phil

smtalk
08-27-2007, 02:41 PM
Try:


chown -R webapps:webapps /var/www/html/webmail

PhilipL
08-27-2007, 03:03 PM
Ok that worked for webmail.

What about squirrelmail?

smtalk
08-27-2007, 03:05 PM
Just do the same :)



chown -R webapps:webapps /var/www/html/squirrelmail-1.4.10a

PhilipL
08-27-2007, 03:33 PM
Ok. That worked too. lol

Thanks for the help.

smtalk
08-27-2007, 03:34 PM
You're welcome. Just added to the CustomBuild FAQ :) Have a nice day!

PhilipL
08-27-2007, 03:51 PM
Cool. nice. Could someone please make the CustomBuild FAQ a sticky?

smtalk
11-04-2007, 03:14 AM
It's sticky now :)

Zyrohost
05-30-2008, 02:59 PM
How about this one?

Error connecting to IMAP server: localhost.
61 : Connection refused

That is squirell mail. I had that smarty problem with the eubia mail or what ever it is but got it fixed. This squirell mail issue is killing me. Can it be fixed? My users would rather use it verses the other choice.

My box is unix running php4 and mysql5

I know i should update my php as well. :o

Thanks in advance either way.


Ray


Oh and I did run the cmd that was posted in another thread but it was a no go as well.

smtalk
05-30-2008, 11:57 PM
Try: http://help.directadmin.com/item.php?id=18

Dauser2007
05-31-2008, 09:45 PM
When i send email have follow error:


ERROR:
Message not sent. Server replied:
Requested action aborted: error in processing
451 Temporary local problem - please try later




any idea ?

smtalk
06-11-2008, 08:39 AM
Dauser2007's problem was not CustomBuild-related. The problem was with ClamAV permissions.