PDA

View Full Version : mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter remove



Zoner
09-30-2007, 12:24 PM
Hi,

just yesterday updated our server's with custombuild (latest) and same time DA to 1.31 version, and update templates:


echo "action=rewrite&value=httpd" >> /usr/local/directadmin/data/task.queue


[warn] [client 217.140.252.186] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed
[Sun Sep 30 12:03:13 2007] [warn] [client ::1] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed

Updated custombuild:

OS: Debian 3.1 (sarge)
Apache/2.2.6 (Unix) / mod_ssl/2.2.6
(su)PHP: 5.2.4

dont know what cause this ...

Also this very weird: [notice] Apache/2.2.6 (Unix) mod_ssl/2.2.6 `G\t\b^\xde\x0e\b DAV/2 configured -- resuming normal operations

->

`G\t\b^\xde\x0e\b

Another server, which is identical: [notice] Apache/2.2.6 (Unix) mod_ssl/2.2.6 OpenSSL/0.9.7e DAV/2 configured -- resuming normal operations

Maybe some customer virtualhost which have .htaccess files, or custombuild httpd configuration files cause this error ?

smtalk
11-04-2007, 03:55 AM
It will be fixed soon (in few days) :) You'll just need to download a new apache configuration file from http://files.directadmin.com/services/custombuild/1.1/custombuild/configure/ap2/conf/httpd.conf (when it will be changed).

Dauser2007
04-29-2008, 04:56 PM
it is same from right now :


[Wed Apr 30 06:31:09 2008] [error] [client 88.229.202.227] Invalid method in request NOOP
[Wed Apr 30 06:31:09 2008] [warn] [client 88.229.202.227] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed
[Wed Apr 30 06:32:23 2008] [error] [client 117.22.253.172] Invalid method in request NOOP
[Wed Apr 30 06:32:23 2008] [warn] [client 117.22.253.172] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed

Henrik
07-01-2008, 04:33 PM
I'm seeing this as well... Using custombuild and Apache 2.2.9.

smtalk
07-15-2008, 01:24 PM
http://gentoo-wiki.com/Apache2_Install, take a look at "SSI Not Working".