PDA

View Full Version : Mod_perl issues



nick-a
10-10-2007, 10:00 AM
I try to build mod_perl and get this:


host# ./build mod_perl
Found /usr/local/directadmin/custombuild/mod_perl-2.0.3.tar.gz
Extracting ...
Done.
Configuring mod_perl-2.0.3...
Reading Makefile.PL args from @ARGV
MP_APXS = /usr/sbin/apxs
no conflicting prior mod_perl version found - good.
Configuring Apache/2.2.6 mod_perl/2.0.3 Perl/v5.8.8
[ error] Using Perl 5.8.8 w/o ithreads and 'worker' mpm httpd.
[ error] Failed requirements:
[ error] - Perl built with ithreads (build perl with -Dusethreads)

Done. Making mod_perl-2.0.3...
Trying to make mod_perl...
make: no target to make.

*** The make has failed, do you want to try to make again? (y,n):


So, I get the line from the build script and try it manually:


host# cd mod_perl-2.0.3
host# perl Makefile.PL MP_APXS=/usr/sbin/apxs
Reading Makefile.PL args from @ARGV
MP_APXS = /usr/sbin/apxs
no conflicting prior mod_perl version found - good.
Configuring Apache/2.2.6 mod_perl/2.0.3 Perl/v5.8.8
[ error] Using Perl 5.8.8 w/o ithreads and 'worker' mpm httpd.
[ error] Failed requirements:
[ error] - Perl built with ithreads (build perl with -Dusethreads)


I'm using freebsd, and the mpm worker module with apache 2.2 (which I did using custombuild)

Any ideas please? I've checked the mod perl site but cant find any useful command line arguments there either.

Rgds,
Nick

smtalk
03-31-2008, 02:04 PM
Try:


./build update
./build all d