PDA

View Full Version : configure: error: Did not find pcre-config script at /usr



jancat
01-06-2008, 09:46 PM
configure: error: Did not find pcre-config script at /usr

*** There was an error while trying to configure Apache 2. Check the configure/ap2/configure.apache file

I`m using centos 4.6 final gcc-3.4.6-9 ?

smtalk
01-06-2008, 11:22 PM
Hello,

Try:


yum -y install pcre-devel

Deef
01-07-2008, 01:17 AM
I had the same problem. Answer from DA support:

configure/ap2/configure.apache

and remove:
"--with-pcre=/usr" \

mattb
01-07-2008, 06:30 AM
Installing pcre-devel is the answer.

You can remove the "--with-pcre=/usr" \ line however if you need to build additional modules such as mod_security you will find you need the line there.

SajtXL
01-11-2008, 04:25 PM
I had the same problem. CentOS Linux 4.6

"configure: error: Did not find pcre-config script at /usr/local"

I have pcre-devel installed,
and have remove "--with-pcre=/usr" \ from configure/ap2/configure.apache :confused: Any suggestions?

Gunnar

smtalk
01-11-2008, 05:40 PM
Try:


./build update
./build pcre
./build apache

SajtXL
01-12-2008, 02:48 AM
Try:


./build update
./build pcre
./build apache



Thank you smtalk for a excellent work, now the ./build apache works as expect :)

/ Gunnar