View Full Version : Cannot load /usr/lib/apache/libphp5.so

01-24-2008, 01:17 AM

yesterday i tryed to upgrade my server with php5, mysql5, apache2 before i was already running php5, mysql4.1 and apache2.

I tryed the ./build all d everytjhing looked good when a wake up this morning but after trying to /etc/init.d/httpd start i got the following error:

Starting httpd: httpd: Syntax error on line 17 of /etc/httpd/conf/httpd.conf:
Cannot load /usr/lib/apache/libphp5.so into server:
/usr/lib/apache/libphp5.so: undefined symbol: EVP_CIPHER_CTX_block_size

Offcource after this i tryed recompiling php5 with ./build php n everything looked good, no errors. (still can't find config.log where can i find it?) but still the same error.

Can somebody please help me solve this problem?

Kind regards

01-24-2008, 01:27 AM
Please post your OpenSSL version (I think it's not compiled from the source (update.script)? (because it's often causing problems)).

01-24-2008, 01:50 AM
This is it...

OpenSSL 0.9.8g 19 Oct 2007 (Library: OpenSSL 0.9.8c 05 Sep 2006)

h1359827:/usr/local/directadmin/custombuild# apt-get install openssl
Pakketlijsten worden ingelezen... Klaar (dutch)
Boom van vereisten wordt opgebouwd... Klaar (dutch)
openssl is allready the newest version.

p.s. it's a debian server

My Build options
h1359827:/usr/local/directadmin/custombuild# ./build options
Apache: 2.2.8
Dovecot: 1.0.10
exim.conf update: no
MySQL: 5.0.45
PHP: 5.2.5 as CLI with mail() header patch
phpMyAdmin: 2.11.4-all-languages
ProFTPD: 1.3.1
RoundCube webmail: 0.1-rc2
Run "clean" every time: yes
SquirrelMail: 1.4.13
Zend Optimizer: no

DirectAdmin Support
01-24-2008, 05:09 PM

Googling around didn't give me a whole lot of insight, but the common theme to the issues was either old versions of openssl, or two installs of openssl at the same time.

You've got g, which is newer than the ones mentioned while googling (d and e), so I'm guessing it might be a double openssl install...

Check to see if you've got 2 installs of openssl, try:

dpkg --get-selections | grep ssl

and maybe see if you can delete all openssl, libssl, libssl-dev libs and reinstall them (without breaking anything.. not even sure if that's possible)..


05-04-2008, 04:15 PM
Got the same problem here:

libssl-dev install
libssl0.9.7 install
libssl0.9.8 install
openssl install

How do i remove it?

05-04-2008, 04:50 PM
Removed and reinstalled (using apt-get remove) but still getting the same problem as in the first post :(

05-05-2008, 04:11 AM
May I take a look at your server (for free)?

11-02-2008, 09:30 AM
It should be fixed in PHP 5.2.7 and 5.3: http://bugs.php.net/bug.php?id=45711

01-05-2009, 05:23 AM
It should be fixed in PHP 5.2.7 and 5.3: http://bugs.php.net/bug.php?id=45711

Ran onto this same error: