PDA

View Full Version : php4 and 5



webaltern
02-17-2008, 11:21 AM
Hi everyone! I want to install php4 and php5 on the same server. I see it's possible via custombuild, I set default_php to 4 and i have also change php5_cgi to yes. All others PHP options are off. I make ./build php and I can just use php 5.. But previously I have installed php4.. So it's suppose to be already there...

Want I'm doing wrong?

smtalk
02-17-2008, 12:08 PM
Do you have php4_cli(cgi) set to yes too? If yes, you need to run "./build php n" or "./build all d". Then you can choose which one to use for your virtualhost (take a look at CustomBuild FAQ) or use this plug-in: http://directadmin.com/forum/showthread.php?t=24152.

webaltern
02-17-2008, 12:50 PM
I don't set 2 options of php to on like said in the custombuild faq



4. How to use options.conf?
* Do not set 2 versions of PHP to "yes".
* After the changes every time run "./build update_data"


did I need to put php4 and php5 cgi to yes? Or just make php4 cgi and php5 cgi after and leave php_default to 4?

smtalk
02-17-2008, 01:03 PM
Thank you for the quote, just updated it :) Take a look at it now. Yes, you need have both PHP4 and PHP5 set to yes.