PDA

View Full Version : #0x800ccc0f - Connection problem



streamservice
02-19-2008, 09:35 AM
Hello,

Could someone say me how I can fix the error above (#0x800ccc0f - connection problem)? I cannot find it in the logs why it happens, maybe i did look to the wrong log (so maybe you can say where i have to look).

The error when I try to login to that account with telnet (just to test the login):


+OK Logged in.
-ERR [IN-USE] Couldn't open INBOX: Internal error occurred. Refer to server log for more information. [2008-02-19 18:33:30]
Connection closed by foreign host.


How can I fix it?

chatwizrd
02-19-2008, 02:58 PM
Check the logs:

/var/log/maillog

/var/log/exim/paniclog
/var/log/exim/mainlog
/var/log/exim/rejectlog

If it is a pop3 problem it will mainly be logged into /var/log/maillog

0x800ccc0f is a windows error and relates to nothing on the server side. From looking it up online it says its a connection interrupted. You will have to look in the logs to find out what is happening.

streamservice
02-20-2008, 12:21 AM
Check the logs:

/var/log/maillog

/var/log/exim/paniclog
/var/log/exim/mainlog
/var/log/exim/rejectlog

If it is a pop3 problem it will mainly be logged into /var/log/maillog

0x800ccc0f is a windows error and relates to nothing on the server side. From looking it up online it says its a connection interrupted. You will have to look in the logs to find out what is happening.

It is a POP3 problem. In /var/log/maillog there are only lines related to this that I can find that are below (they don't point me to the solution):


Feb 19 18:33:30 server dovecot[13462]: auth(default): shadow(webmaster@domain.com,89.248.170.35): unknown user
Feb 19 18:33:30 server dovecot[13462]: auth(default): passwd(webmaster@domain.com,89.248.170.35): unknown user
Feb 19 18:33:30 server dovecot[13462]: pop3-login: Login: user=<webmaster@domain.com>, method=PLAIN, rip=89.248.170.35, lip=89.248.170.31
Feb 19 18:33:30 server dovecot[13462]: POP3(webmaster@domain.com): stat(/home/domain/imap/domain.com/webmaster/Maildir/cur) failed: Permission denied
Feb 19 18:33:30 server dovecot[13462]: POP3(webmaster@domain.com): stat(/home/domain/imap/domain.com/webmaster/Maildir/cur) failed: Permission denied
Feb 19 18:33:30 server dovecot[13462]: POP3(webmaster@domain.com): Couldn't open INBOX: Internal error occurred. Refer to server log for more information. [2008-02-19 18$
Feb 19 18:33:30 server dovecot[13462]: POP3(webmaster@domain.com): Couldn't open INBOX top=0/0, retr=0/0, del=0/0, size=0

Permission for /home/domain/imap/domain.com/webmaster/Maildir/cur is 770 (user: domain, group: mail).

Domainname and username are changed. But they shouldn't be the cause off the problem.

chatwizrd
02-20-2008, 12:27 AM
Try this first:

cd /usr/local/directadmin/scripts
./set_permissions.sh all

streamservice
02-20-2008, 12:43 AM
Try this first:

cd /usr/local/directadmin/scripts
./set_permissions.sh all

Thank you. That fixed it.

chatwizrd
02-20-2008, 12:50 AM
Glad to hear it :)