PDA

View Full Version : Problem build suphp



Conrad
04-03-2008, 02:01 PM
It's not the first time i installed DA with custombuild 1.1 on FreeBSD 6.2

but now on the next server is suddenly got errors when trying to build
suphp:

../config/install-sh: Permission denied
*** Error code 126

Stop in /usr/local/directadmin/custombuild/suphp-0.6.3/src.
*** Error code 1

everything else is ok.

Anyone has a solution for this?

chatwizrd
04-03-2008, 02:25 PM
are you logged in under root user?

Conrad
04-03-2008, 02:29 PM
yes, i just installed a new DA but the only problem is that i cannot
build suphp because of the permission error.

i have two others servers running with the same configuration.

php4 as cgi and php5 as cli (default)

i think it must be the version of suphp, because the other servers
still have version 0.6.2 ??

Conrad
04-04-2008, 02:57 PM
Problem solved.

it seemed that some files in the suphp.0.6.3 had wrong permissions.
Thanks to John, he replaced the tar.gz.

After a ./build update and ./build suphp everything is working now.

Thanks to those who helped me out.

valic
04-06-2008, 04:39 AM
i have smo problems with suphp or i have something skip?

i have build custombuild 1.1:

Apache: 2.2.8
Dovecot: 1.0.13
exim.conf update: no
MySQL: 5.0.51a
MySQL backup: no
PHP: 5.2.5 as CGI with mail() header patch
phpMyAdmin: 2.11.5.1-all-languages
ProFTPD: 1.3.1
RoundCube webmail: 0.1
Run "clean" every time: yes
SquirrelMail: 1.4.13
UebiMiau: no
Zend Optimizer: 3.3.3


but then it's 500 Internal server error
when i build php 5.2.5 as cli , it's ok.

i have built last suphp.
what is e problem, have i something forgott to do, or?

Sorry on my bad english:eek:

Conrad
04-06-2008, 05:08 AM
when u use suphp and get the 500 error, then make sure
the ownership of the php file is correct, for example admin:admin

other thin you can do is have al look at:
http://help.directadmin.com/item.php?id=176

it saved me from a lot of question from customers.

smtalk
04-06-2008, 05:15 AM
Or take a look at /var/log/suphp.log :)

Conrad
04-06-2008, 05:33 AM
that can help too :)

valic
04-06-2008, 05:41 AM
tnx, but it's not working yet

i give example from one domain

http://help.directadmin.com/item.php?id=176
- i have execute this(in owner instead paranoid), but nothing work
-suPHP_UserGroup username username --> in httpd configuration from each domain , i.e:

# Auto generated apache config file by DirectAdmin version 1.31.4
# Modifying this file is not recommended as any changes you make will be
# overwritten when the user makes any changes to his/her website

# Frontpage requires these parameters in every httpd.conf file or else
# it won't work.
ServerRoot /etc/httpd



<VirtualHost 66.79.163.234:80>


ServerName www.strojar.info
ServerAlias www.strojar.info strojar.info
ServerAdmin webmaster@strojar.info
DocumentRoot /home/strojko/domains/strojar.info/public_html
ScriptAlias /cgi-bin/ /home/strojko/domains/strojar.info/public_html/cgi-bin/

UseCanonicalName OFF

SuexecUserGroup strojko strojko
CustomLog /var/log/httpd/domains/strojar.info.bytes bytes
CustomLog /var/log/httpd/domains/strojar.info.log combined
ErrorLog /var/log/httpd/domains/strojar.info.error.log

<Directory /home/strojko/domains/strojar.info/public_html>
Options +Includes -Indexes



suPHP_Engine ON
#suPHP_UserGroup strojko strojko

</Directory>



</VirtualHost>



<VirtualHost 66.79.163.234:443>

SSLEngine on
SSLCertificateFile /etc/httpd/conf/ssl.crt/server.crt
SSLCertificateKeyFile /etc/httpd/conf/ssl.key/server.key


ServerName www.strojar.info
ServerAlias www.strojar.info strojar.info
ServerAdmin webmaster@strojar.info
DocumentRoot /home/strojko/domains/strojar.info/private_html
ScriptAlias /cgi-bin/ /home/strojko/domains/strojar.info/public_html/cgi-bin/

UseCanonicalName OFF

SuexecUserGroup strojko strojko
CustomLog /var/log/httpd/domains/strojar.info.bytes bytes
CustomLog /var/log/httpd/domains/strojar.info.log combined
ErrorLog /var/log/httpd/domains/strojar.info.error.log

<Directory /home/strojko/domains/strojar.info/private_html>
Options +Includes -Indexes



suPHP_Engine ON
suPHP_UserGroup strojko strojko

</Directory>



</VirtualHost>


-/var/log/suphp.log - it's empty, but in /var/log/httpd/domains/strojar.info.error.log it's last line ---> No user or group set - set suPHP_UserGroup

smtalk
04-06-2008, 06:14 AM
You get this error, because this line is commented out and suPHP is still running in paranoid instead of owner mode, because only paranoid mode requires suPHP_UserGroup:

#suPHP_UserGroup strojko strojko

valic
04-06-2008, 03:52 PM
You get this error, because this line is commented out and suPHP is still running in paranoid instead of owner mode, because only paranoid mode requires suPHP_UserGroup:

#suPHP_UserGroup strojko strojko

tnx, it's working:)

but the new problem is when i extract tar.gz in filemanager, extracted files and folder have permissions set to 777, instead 755 and 644( creating folder and uploading files through filemanager it's ok)

DirectAdmin Support
04-22-2008, 05:43 PM
Hello,

Permissions are stored inside the tar.gz. DA doesn't set them after a tar.gz is extracted.

You can verify this by typing:

tar tvzf file.tar.gz

from ssh.
Tar is simply setting them to exactly what they were before they were compressed.

John

ehsanch
08-07-2008, 03:32 AM
hello

i have same problem, we are in windows and there is no permission like linux... how set permission in tar.gz files ? is it not possible to set an option in DA to reset permissions after exrtract ?

nobaloney
08-07-2008, 05:02 AM
I'm not sure what you're looking for. Are you creating the tarballs on Windows? If so, then you have to figure out how to tell the program to use to create the permissions you want.

Are you opening the tarballs on Windows? If so, then the permissions shouldn't matter; Windows should just ignore them.

The only command built into gnu-tar will set all permissions according to the user's umask:

From the tar manual:

<snip>
--no-same-permissions
apply umask to extracted files (the default for non-root users)
</snip>

But you'd have to set your umask first to what you want for the various subdirectories into which you're unpacking, and then run tar manually.

DirectAdmin could implement this only if everyone would be using the same umask, and if the directories would be set to that first, before the tarball is unpacked.

I don't know if the option exists in non-linux systems; I didn't check the manual for FreeBSD.

Jeff