PDA

View Full Version : Something went wrong with PHP4 CGI + PHP5 CGI



tillo
05-19-2008, 11:11 AM
I always had this config, never configured custombuild to build PHP5 as CLI... but I know that there must be a PHP5 CLI for DirectAdmin, therefore custombuild was building it anyway...

Here is the update_versions result after the last update:



# ./build options |grep PHP
PHP: 5.2.6 as CGI with mail() header patch
PHP: 4.4.8 as CGI with mail() header patch
PHP: 4.4.8 as CGI and 5.2.6 as CGI (default: PHP 5.2.6) with mail() header patch
# ./build update_versions
Updating PHP5 (CLI)
File already exists: php-5.2.6.tar.gz
MD5 Checksum on php-5.2.6.tar.gz passed.
File already exists: php-5.2.6-mail-header.patch
MD5 Checksum on php-5.2.6-mail-header.patch passed.
Can not build PHP5 as CLI because it is not set in options.conf.


Why is it trying to update PHP5 CLI as if I explicitly asked for it?

smtalk
05-20-2008, 02:51 AM
Are you sure you have the latest version of the CustomBuild script?

tillo
05-20-2008, 04:07 AM
Sure, I always do ./build update before trying to upgrade. I've version 1.1.11 since last week; it's since this version that I've got the problem, but I don't remember which version I had before... I've not upgraded the custombuilded system in a while (a month or so).

I realized ./build versions tells me I've got PHP5 CLI + PHP4 CGI + PHP5 CGI installed; this is the reason update_versions want to upgrade them all; does this help? How can I tell it PHP5 CLI "is not installed"?

smtalk
05-20-2008, 07:03 AM
tillo, thank you for the report :) I'll fix this problem soon.

smtalk
05-21-2008, 03:04 PM
It's fixed now. Good luck! :)