PDA

View Full Version : Default PHP error!



Herbert
08-23-2008, 02:35 PM
Hello,
i'am running PHP 4.4.9 and PHP 5.2.6 in CGI with SUPHP
After update PHP 4.4.8 to 4.4.9 is the default PHP version is 4.4.9
I try everything to set default to PHP 5.2.6 but notting works.
Only in .htaccess i get PHP 5.2.6 with:

<FilesMatch "\.(inc|php|php3|php4|php5|php6|phtml|phps)$">
AddHandler x-httpd-php5 .php
</FilesMatch>

Here my config:

default_php=5
php5_cli=no
php5_cgi=yes
php6_cli=no
php6_cgi=yes
php4_cli=no
php4_cgi=yes
php_ini=no
#Possible values - recommended or dist
php_ini_type=recommended
zend=yes
...
..

I use BUILDSCRIPT_VER=1.1.13
Please help..

smtalk
08-23-2008, 03:19 PM
So, what's the problem? :) You get PHP5 as you want.

Herbert
08-23-2008, 03:56 PM
So, what's the problem? :) You get PHP5 as you want.
The problem:
I try everything to set default to PHP 5.2.6 but notting works.

smtalk
08-23-2008, 03:58 PM
<FilesMatch "\.(inc|php|php3|php4|php5|php6|phtml|phps)$">
AddHandler x-httpd-php5 .php
</FilesMatch>

Does not work?

Herbert
08-23-2008, 04:34 PM
<FilesMatch "\.(inc|php|php3|php4|php5|php6|phtml|phps)$">
AddHandler x-httpd-php5 .php
</FilesMatch>

Does not work?
Hello,
Yes that works, my problem is the default PHP that must be 5.2.6
All my client domains running now under PHP 4.4.9 that is not good.
I try this: ./build php5-cgi n
The output in shell is: PHP 5.2.6 (cli)

smtalk
08-24-2008, 03:32 AM
Did you read the "help" page? These functions are only recommended for experienced users. So, why don't you use "./build php n" ? And make sure you have default_php=5.

Dravu
08-24-2008, 02:17 PM
Never tried running both side-by-side before (so sorry if this is just a dumb question), but according to your config, you're trying to run both versions as CGI? Doesn't one have to be CLI?

smtalk
08-24-2008, 02:44 PM
Dravu, you can run both as CGI (but not CLI) if you want :)

Dravu
08-24-2008, 03:22 PM
Dravu, you can run both as CGI (but not CLI) if you want :)
ah. I was just curious. :)