PDA

View Full Version : Problems after changing from customapache to custombuild



RJay
09-11-2008, 06:27 PM
I'm new to directadmin and linux but after changing from customapache to custombuild when I restart httpd I get:

Stopping httpd: [ OK ]
Starting httpd: [Thu Sep 11 17:11:53 2008] [error] (EAI 2)Name or service not known: Cannot resolve host name |IP| --- ignoring!
[Thu Sep 11 17:11:53 2008] [error] (EAI 2)Name or service not known: Cannot resolve host name |IP| --- ignoring!
[Thu Sep 11 17:11:53 2008] [warn] NameVirtualHost XXX.XXX.XXX.XXX:80 has no VirtualHosts
[Thu Sep 11 17:11:53 2008] [warn] NameVirtualHost XXX.XXX.XXX.XXX:443 has no VirtualHosts
[Thu Sep 11 17:11:53 2008] [warn] NameVirtualHost XXX.XXX.XXX.XXX:80 has no VirtualHosts
[Thu Sep 11 17:11:53 2008] [warn] NameVirtualHost XXX.XXX.XXX.XXX:443 has no VirtualHosts

and all my pages have just a line of text saying "Apache is functioning normally".

chatwizrd
09-12-2008, 06:15 AM
Looks like it didnt change the ip from the template.

You could try

cd /usr/local/directadmin/custombuild
./build rewrite_confs

RJay
09-14-2008, 02:55 PM
Thanks that seemed to work

RJay
09-14-2008, 03:04 PM
I take that back now I am getting a 500 server error in the faqs it says to check suphp.log but it is a blank file.

RJay
09-14-2008, 08:33 PM
I think it is a problem with my php I tried a ./build php d and got this


checking for MySQL support... no
checking for specified location of the MySQL UNIX socket... no
checking for MySQLi support... yes
checking whether to enable embedded MySQLi support... no
checking for mysql_set_server_option in -lmysqlclient... no
configure: error: wrong mysql library version or lib not found. Check config.log for more information.

*** There was an error while trying to configure php. Check the configure/suphp/configure.php5 file

smtalk
09-15-2008, 02:14 AM
Do:


./build mysql

RJay
09-15-2008, 11:14 AM
Did the ./build mysql and restarted httpd same error. Rebuilt php got


checking for MySQL support... yes
checking for specified location of the MySQL UNIX socket... no
checking for MySQL UNIX socket location... no
checking for mysql_close in -lmysqlclient... no
checking for mysql_error in -lmysqlclient... no
configure: error: mysql configure failed. Please check config.log for more information.

*** There was an error while trying to configure php. Check the configure/suphp/configure.php5 file
And now httpd restart gives

service httpd restart
Stopping httpd: [FAILED]
Starting httpd: Syntax error on line 32 of /usr/local/directadmin/data/users/flvnet/httpd.conf:
Invalid command 'suPHP_Engine', perhaps mis-spelled or defined by a module not included in the server configuration Tried a ./build suphp but got the same warning

smtalk
09-15-2008, 12:28 PM
Make sure you do not have any custom templates. About the MySQL problem - I can take a look at it if you want.

RJay
09-16-2008, 07:17 PM
I just got a email from my host saying that I'm going to get assigned new ips so as soon as that is done I will send you the info.

Thanks
RJ