View Full Version : Majordomo, how to install?

09-15-2008, 10:59 AM
When I setup DA + Custombuild 1.1 + Apache 2.2 + PHP 5 CGI on CentOS 5.2 64 bits, I got an error below:

The source path for majordomo does not exist. Make sure the correct path is set in majordomo.sh

After I was done with setup. I installed Exim RPM from DA. Then, I tried to start Exim Service but I couldn't with the following error :

Shutting down exim:
Starting exim: 2008-09-15 23:14:30 Exim configuration error in line 590 of /etc/exim.conf:
user majordomo was not found

I then, try to run script ./majordomo.sh and got error The source path for majordomo does not exist. Make sure the correct path is set in majordomo.sh

I looked into the script and it said the file should be in scripts/packages but there is no packages directory at all.

I would like to know if I really need it? If yes, why DA didn't install it at first? And where to get majordomo file? (I've search files.directadmin.com/services but couldn't find it.) Can I get from http://www.greatcircle.com/majordomo/ and put it in packages?

Suzuki gs series specifications (http://www.suzuki-tech.com/wiki/Suzuki_GS_series)

DirectAdmin Support
09-21-2008, 01:11 AM

The majordomo tar.gz file should be in:


That files needs to be extracted before majordomo.sh is run, so if you don't have it, type:
cd /usr/local/directadmin/scripts/packages
wget -O majordomo-1.94.5.tar.gz http://files.directadmin.com/services/9.0/majordomo-1.94.5.tar.gz
tar xvzf majordomo-1.94.5.tar.gz
cd ..

09-22-2008, 10:28 AM
I didn't have that file on my server the first time I've installed. (For the location you said.) Then, for some reason, I had to wipe out everything and re-install OS again. This time, I found it in directory you said :)

Thank you,
Medical Marijuana Patients (http://mmjp.org)

12-26-2009, 01:10 AM
Yu don't need to reinstall OS, jut download and run majordomo.sh as decribed by DA support.

01-05-2010, 07:38 AM
I have Debian 5.0.3, 32bit, fresh installation of Directadmin, and have same issues..

i did as (root):
cd /usr/local/directadmin/scripts

and i have this:

make: `wrapper' is up to date.
Testing for perl (/usr/bin/perl)...
Configuring scripts...
./install.sh -m 751 -O 1005 -g 1 . /etc/virtual/majordomo
./install.sh -m 755 -O 1005 -g 1 . /etc/virtual/majordomo/bin
Copying tools to /etc/virtual/majordomo/bin
Copying Majordomo files to /etc/virtual/majordomo
Copying archiving and other tools to /etc/virtual/majordomo/Tools
./install.sh -m 755 -O 1005 -g 1 . /etc/virtual/majordomo/Tools
Using installed majordomo.cf
Installing manual pages in /etc/virtual/majordomo/man

To finish the installation, 'su' to root and type:

make install-wrapper

If not installing the wrapper, type

cd /etc/virtual/majordomo; ./wrapper config-test

(no 'su' necessary) to verify the installation.
./install.sh -o root -g 1 \
-m 4755 wrapper /etc/virtual/majordomo/wrapper

To verify that all the permissions and etc are correct,
run the command

cd /etc/virtual/majordomo; ./wrapper config-test

i have tried to do:

MYSRV:/usr/local/directadmin/scripts# make install-wrapper
make: *** No rule to make target `install-wrapper'. Stop.

how can i fix majordomo ?? (my exim is stopped because user majordom doesnt exists)

thank you

01-05-2010, 11:40 AM
The rule will exist only if you run this from the majordomo subdirectory. I've never had to run the script; majordomo gets installed with DirectAdmin, so I'm not sure what you're doing or why.

Or am I missing something?


01-05-2010, 11:48 AM
The problem was, after clear install on Debian that exim was not running at all, and mail doesnt arrive..

At log a saw:
Exim configuration error in line 590 of /etc/exim.conf:
(i don't remember was it 590 or similar..)
and this line was about to add safe senders or similar (admin, majordomo and so on), and error was:
user majordomo was not found

so i tried what DirectAdmin Support wrote above..., and i get messages as i described..

also i have tried and done this: http://help.directadmin.com/item.php?id=66

now, the error still persist, but after restart my exim is working fine, and mail is working..,
(but still majordomo.sh have failures as i described above)

anyway, mail is working and let's say that this is solved for now.