PDA

View Full Version : Libtool update fails



Henrik
10-05-2008, 09:30 PM
Hello,


There are some updates out for CustomBuild, though the update of Libtool fails.



# ./build update_versions
Updating libtool
File already exists: libtool-2.2.6a.tar.gz
MD5 Checksum on libtool-2.2.6a.tar.gz passed.
Found /usr/local/directadmin/custombuild/libtool-2.2.6a.tar.gz
Extracting ...
Done.
./build: line 4454: cd: libtool-2.2.6a: No such file or directory
Configuring libtool-2.2.6a...
./build: line 4457: ./configure: is a directory
Done. Making libtool-2.2.6a...
Trying to make libtool...
make: *** No targets specified and no makefile found. Stop.


Help?


EDIT: This is on Centos 4.7.

floyd
10-06-2008, 05:43 AM
"./build: line 4454: cd: libtool-2.2.6a: No such file or directory"

Henrik
10-06-2008, 05:44 AM
You're having similar errors, or you are quoting my post?

floyd
10-06-2008, 06:00 AM
I am quoting your post showing you where the problem is.

Henrik
10-06-2008, 06:03 AM
Yes. I figured as much - thanks for pointing it out though.

Moving on; I am not posting here about that, but rather to get a solution to the above.

(Thanks)

floyd
10-06-2008, 06:12 AM
Ok I will spell it out a little more.

If the script cannot cd into libtool-2.2.6a then there must be something wrong with the .tar.gz file. Or its not creating the expected directory. Have you tried tar -xzf libtool-2.2.6a.tar.gz to see if it extracts properly? What directory does it create?

In solving any problem you have to start at the point of the first failure. That is basic diagnostic procedure. That is what I pointed out. That is where your solution lies.

Henrik
10-06-2008, 06:25 AM
I realize that, though according to what we both are thinking - something is up with the compressed source file, and thus it would be something for the author(s) of custombuild to have a look at. (And that's also why I posted this thread, both to investigate and also notify.)

Email has been sent directly to the DA support too of course.

Cheers Floyd! :)

floyd
10-06-2008, 06:38 AM
I have always viewed the purpose of this forum was to help the users fix their own problem rather than notify the authors of any problem. If you want to notify the author of Custom build then you need to notify smtalk.

I was trying to help you diagnose and solve the problem yourself. But if you would rather wait then that is up to you. I was willing to help you now.

Henrik
10-06-2008, 07:48 AM
Floyd, the reason to why I posted here was to not have other users (on the same distribution as myself) having to ask the same question more than once, thus actually saving John&co time. As the checksum seem to be correct, there might be something up with the file when it was created.

Yes, I have sent a notification to Martynas as well - and he'll probably be around to have a peek.

But enough of semantics/meta discussions, let's await a response from DA&Martynas.



PS. I know you mean well, so thanks for that.

smtalk
10-06-2008, 07:52 AM
The problem is that the libtool-2.2.6a.tar.gz package has libtool-2.2.6 folder in it (not libtool-2.2.6a). The problem should be solved soon by John.

floyd
10-06-2008, 07:59 AM
The problem is that the libtool-2.2.6a.tar.gz package has libtool-2.2.6 folder in it (not libtool-2.2.6a).

Finally the answer I was asking about. Now the question can be answered.


The problem should be solved soon by John.

Or if one does not want to have to wait one can create a link from libtool-2.2.6a to libtool-2.2.6 and be done with it. Simple solution. But I did not want to post what I thought would be the solution before getting the answer to what directory tar -xzf libtool-2.2.6a.tar.gz creates. Henrik may be willing to wait but I try answer questions so that all can benefit.

Henrik
10-06-2008, 08:09 AM
Thank you for the notice, Martynas.


I try answer questions so that all can benefit.

That's what the thank you was for above, Floyd. (Sometimes one doesn't see the forest for all the trees ;))

DirectAdmin Support
10-06-2008, 03:39 PM
Hello,

The issue was that the included directory of the tar.gz was 2.2.6 while the version was 2.2.6a. I've recompressed the file with a renamed directory and updated the versions file.

Type:

./build update

to get the new version.

John

DirectAdmin Support
10-07-2008, 04:47 PM
Just an update, that it looks like even within the code/libs of libtool, they only have the version set to 2.2.6, not 2.2.6a. This means that the "libtool --version" will return 2.2.6, even though you're running 2.2.6a. (*shakes finger and libtool people*).. in any case, just an FYI that the build script will tell you that the version needs updating, when it doesn't. I'll keep my eye open for a clean solution (possibly just editing the /usr/local/bin/libtool file to the correct version). I may end up just changing the tar.gz to 2.2.6 and pretend that 2.2.6a doesn't exist.. since the md5sum check would guarntee you have the latest version anyway...

John

BDConsult
10-27-2008, 03:00 AM
Any news about this? I'am getting "update" email every day on this moment from alle the DA servers.

smtalk
10-27-2008, 03:05 AM
It's fixed, you shouldn't get emails about libtool 2.2.6 update anymore.