PDA

View Full Version : dovecot - Err Authentication Failed



dovecot_learner
08-22-2010, 07:00 AM
Hello,

I am trying to setup Postfix along with dovecot on RHEL4.

I have done the necessary settings in dovecot.conf, yet I am not able to log into the POP3 server. The error I can see through WireShark/Ethereal is "Err- Authentication failed"

Some of the important settings in /etc/dovecot.conf are

disable_plaintext_auth = no
auth_mechanisms = plain
auth_userdb = passwd
auth_passdb = pam
auth_user = root

The users/passwords are setup on Linux file system without MQSql or any other database. SASL etc is not configured at all.

Please assist.

Thanks.

dovecot_learner
08-22-2010, 11:31 AM
Ok.

I have modified the /etc/pam.d/dovecot file as per dovecot wiki
http://wiki.dovecot.org/PasswordDatabase/PAM

i.e.
auth required pam_unix.so nullok
account required pam_unix.so

Now I am getting 'unknown user' error as below. Please assist in resolving this issue.

Aug 22 20:24:11 PC1 dovecot: auth: Debug: pam(test@mailone.abc.ae,192.168.1.99): lookup service=dovecot
Aug 22 20:24:11 PC1 dovecot: auth: Debug: pam(test@mailone.abc.ae,192.168.1.99): #1/1 style=1 msg=Password:
Aug 22 20:24:13 PC1 dovecot: auth: pam(test@mailone.abc.ae,192.168.1.99): unknown user
Aug 22 20:24:15 PC1 dovecot: auth: Debug: client out: FAIL 1 user=test@mailone.abc.ae
Aug 22 20:24:15 PC1 dovecot: pop3-login: Disconnected (auth failed, 1 attempts): user=<test@mailone.abc.ae>, method=PLAIN, rip=192.168.1.99, lip=192.168.1.117, mpid=0

Regards.

nobaloney
08-23-2010, 12:15 PM
I guess there's a reason why you posted here; probably because we've got a Dovecot subforum.

We're a forum for the DirectAdmin (http://www.directadmin.com/) webhosting control panel, and we support DirectAdmin, using Dovecot and Exim. You should probably find another place to post.

Jeff