PDA

View Full Version : upgrade apache 2.2.16 to 2.2.17 error



woolkan
10-27-2010, 01:18 PM
hi,

i have problem. when I update apache 2.2.16 to 2.2.17 I always get error:


/usr/local/directadmin/custombuild/httpd-2.2.17/srclib/apr/libtool --silent --mode=link gcc -g -O2 -pthread -I/usr/local/include -L/usr/local/lib -L/usr/lib -o htpasswd htpasswd.lo -lm -L/usr/local/lib -lpcre /usr/local/directadmin/custombuild/httpd-2.2.17/srclib/apr-util/libaprutil-1.la -lexpat -liconv /usr/local/directadmin/custombuild/httpd-2.2.17/srclib/apr/libapr-1.la -luuid -lrt -lcrypt -lpthread -ldl
/usr/lib/libexpat.so: could not read symbols: File in wrong format
collect2: ld returned 1 exit status
make[2]: *** [htpasswd] Error 1
make[2]: Leaving directory `/usr/local/directadmin/custombuild/httpd-2.2.17/support'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/directadmin/custombuild/httpd-2.2.17/support'
make: *** [all-recursive] Error 1

*** The make has failed, do you want to try to make again? (y,n):


anyone can help me?

best regards,

woolkan
10-27-2010, 01:29 PM
solution was here: http://www.directadmin.com/forum/showthread.php?t=27045