PDA

View Full Version : Error while installing OTRS



larsisgoed9
06-27-2011, 11:54 AM
Hello,

Someone suggests me OTRS for sorting e-mails, so that's why I tried to install those crap. At the install of OTRS, there came an error, so I start searching the error on Google, where I came at the website: http://www.ebizontek.com/yum-has-depsolving-problems-what-do. So I dit that with perl and httpd (removing). Back at the OTRS install I had to change something in the httpd.conf, but I maked a backup of this file. At the point to restart HTTPD I got an error:
Syntax error on line 30 of /etc/httpd/conf/httpd.conf:
Invalid command 'Order', perhaps misspelled or defined by a module not included in the server configuration

Line 30 is this line: (Order allow,deny)


User apache
Group apache

ServerAdmin admin@localhost
DocumentRoot "/var/www/html"

<Directory /home/*>
AllowOverride All
Options -MultiViews -Indexes FollowSymlinks IncludesNoExec +Includes
<Limit GET POST OPTIONS PROPFIND>
Order allow,deny
Allow from all
</Limit>
<LimitExcept GET POST OPTIONS PROPFIND>
Order deny,allow
Deny from all
</LimitExcept>
</Directory>

The yum.conf contains at the moment:


[main]
cachedir=/var/cache/yum
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
distroverpkg=redhat-release
tolerant=1
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1

# Note: yum-RHN-plugin doesn't honor this.
metadata_expire=1h

# Default.
# installonly_limit = 3

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d
exclude=apache* mod_* mod_perl* httpd_* httpd* mysql* MySQL* da_* *ftp*
exim*
sendmail* php*
bind-chroot*


I tried all mod_perl and httpd combinations, I restored the httpd.conf, I rebooted the VPS server, but nothing works.

Hopefully someone of you knows what to do.

Thanks in advance,

L. Groot

nobaloney
06-27-2011, 02:21 PM
The keyword Order is in all my httpd.conf files, on both apache 1.x and 2.x. How did you compile apache? Did you use custombuild or customapache? Or did you install it from yum?

DirectAdmin's configuration won't work with apache not installed from custombuild or customapache.

Jeff

unnisathya
05-04-2012, 07:04 AM
Hi

I am trying to install OTRS on a debian squeeze OS ... and the machine already has a working apache2 and postgresql database. But when I enter the command

#apt-get install otrs2

It ends up with the following errors

dpkg: error processing otrs2 (--configure):
subprocess installed post-installation script returned error exit status 2
configured to not write apport reports
Errors were encountered while processing:
otrs2
E: Sub-process /usr/bin/dpkg returned an error code (1)

It has successfully created the database though.

Any ideas/help is appreciated

Thanks.

zEitEr
05-04-2012, 09:25 AM
I'd guess you're neither a directadmin user nor an administrator of directadmin powered server. Since that these forums are not the right place to try to find a solution. And even you are either a directadmin user or an administrator of directadmin powered server, you'd better ask your question on OTRS forums or mailing lists.