PDA

View Full Version : Install Zend on CentOS



RAGOpoR
09-01-2011, 11:40 PM
is this solution incorrect ?
is it possible to install Zend Server CE or Zend Server license with directadmin ?
after i run this command my php on server are not work, any idea ?

cd /usr/local/directadmin/custombuild
./build update
./build clean
./build zend
File already exists: ZendGuardLoader-php-5.3-linux-glibc23-x86_64.tar.gz
Zend Guard Loader has been installed.


[root@xs1 custombuild]# php -v
PHP 5.3.6 (cli) (built: Aug 13 2011 20:56:01)
Copyright (c) 1997-2011 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2011 Zend Technologies
with Zend Guard Loader v3.3, Copyright (c) 1998-2010, by Zend Technologies

SeLLeRoNe
09-02-2011, 12:21 AM
Zend Server is not ZendGuard...

You didnt gave any error, log or any usefull information for help you with your issue.

Regarding Zend Server on DA Server, MAYBE, with a lot of customization, should be done on a separate port (different from apache that use 80) and with virtual redirects using apache as proxy.

Regards

RAGOpoR
09-02-2011, 12:35 AM
Zend Server is not ZendGuard...

You didnt gave any error, log or any usefull information for help you with your issue.

Regarding Zend Server on DA Server, MAYBE, with a lot of customization, should be done on a separate port (different from apache that use 80) and with virtual redirects using apache as proxy.

Regards

Thank you for your information.

according to This server running as production, i have to restore it.
could you please show me the solution to enable zend , e.g. zend optimizer
or solution for Zend Server ?

thank you

SeLLeRoNe
09-02-2011, 12:42 AM
You still didnt gave enough information.

Check /var/log/httpd/error_log

Try rebuild php using


/usr/local/directadmin/custombuild/build php d

For recompile php (maybe apache lost the mod for some reason).

Regards

RAGOpoR
09-02-2011, 12:57 AM
You still didnt gave enough information.

Check /var/log/httpd/error_log

Try rebuild php using


/usr/local/directadmin/custombuild/build php d

For recompile php (maybe apache lost the mod for some reason).

Regards

the issues happen between 13.25 - 13.45
i think it no log about php error ?
anyway according to your advise i will try to enable zend and rebuild php again


[Fri Sep 02 00:10:02 2011] [notice] SIGHUP received. Attempting to restart
[Fri Sep 02 00:10:03 2011] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Fri Sep 02 00:10:03 2011] [notice] Apache/2.2.19 (Unix) mod_ssl/2.2.19 OpenSSL/0.9.8e-fips-rhel5 DAV/2 SVN/1.6.5 PHP/5.3.6 configured -- resuming normal operations
[Fri Sep 02 00:11:01 2011] [notice] caught SIGTERM, shutting down
[Fri Sep 02 00:11:02 2011] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Fri Sep 02 00:11:02 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Fri Sep 02 00:11:03 2011] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Fri Sep 02 00:11:03 2011] [notice] Apache/2.2.19 (Unix) mod_ssl/2.2.19 OpenSSL/0.9.8e-fips-rhel5 DAV/2 SVN/1.6.5 PHP/5.3.6 configured -- resuming normal operations
[Fri Sep 02 02:37:49 2011] [error] [client 203.172.175.251] File does not exist: /var/www/html/w00tw00t.at.blackhats.romanian.anti-sec:)
[Fri Sep 02 02:37:49 2011] [error] [client 203.172.175.251] File does not exist: /var/www/html/404.shtml
[Fri Sep 02 02:37:49 2011] [crit] [client 203.172.175.251] (13)Permission denied: /var/www/html/phpMyAdmin/scripts/.htaccess pcfg_openfile: unable to check htaccess file, ensure it$
[Fri Sep 02 02:37:49 2011] [error] [client 203.172.175.251] File does not exist: /var/www/html/403.shtml
[Fri Sep 02 02:37:49 2011] [crit] [client 203.172.175.251] (13)Permission denied: /var/www/html/phpMyAdmin/scripts/.htaccess pcfg_openfile: unable to check htaccess file, ensure it$
[Fri Sep 02 02:37:49 2011] [error] [client 203.172.175.251] File does not exist: /var/www/html/403.shtml
[Fri Sep 02 02:37:49 2011] [error] [client 203.172.175.251] File does not exist: /var/www/html/pma
[Fri Sep 02 02:37:49 2011] [error] [client 203.172.175.251] File does not exist: /var/www/html/404.shtml
[Fri Sep 02 02:37:49 2011] [error] [client 203.172.175.251] File does not exist: /var/www/html/myadmin
[Fri Sep 02 02:37:49 2011] [error] [client 203.172.175.251] File does not exist: /var/www/html/404.shtml
[Fri Sep 02 02:37:49 2011] [error] [client 203.172.175.251] File does not exist: /var/www/html/MyAdmin
[Fri Sep 02 02:37:49 2011] [error] [client 203.172.175.251] File does not exist: /var/www/html/404.shtml

SeLLeRoNe
09-02-2011, 12:59 AM
I dont see any relevant error here.

What problem you got exactly?

From your php -v seems that zend is installed.

RAGOpoR
09-02-2011, 01:26 AM
I dont see any relevant error here.

What problem you got exactly?

From your php -v seems that zend is installed.

i do following your advise

after enable zend then build zend

then recompile php, it seem php work well but what about zend optimizer ?
i don't know why it install only Zend Guard, any idea ?

PHP 5.3.6 (cli) (built: Sep 2 2011 12:37:24)
Copyright (c) 1997-2011 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2011 Zend Technologies
with Zend Guard Loader v3.3, Copyright (c) 1998-2010, by Zend Technologies

SeLLeRoNe
09-02-2011, 01:31 AM
Zend Optimizer doenst exist on php 5.3

Thats why it install Zend Guard.

Regards

RAGOpoR
09-02-2011, 01:43 AM
Zend Optimizer doenst exist on php 5.3

Thats why it install Zend Guard.

Regards

Thank you for your help SeLLeRoNe

Can i ask more question?
is custombuild support Zend Server CE?
if i download and manual install Zend Server CE
it will be conflict with Directadmin ?

SeLLeRoNe
09-02-2011, 02:09 AM
That probably not, but im not sure... Is possible that will no conflict but for sure you need to use zend server not on default 80 port.

Never tested, so i cant be sure, you need to try it on your own im sorry.

Regards

RAGOpoR
09-02-2011, 02:10 AM
That probably not, but im not sure... Is possible that will no conflict but for sure you need to use zend server not on default 80 port.

Never tested, so i cant be sure, you need to try it on your own im sorry.

Regards


Thank you SeLLeRoNe.