PDA

View Full Version : yum update error: Error: pkgKey 4157 doesn't exist in repo base



nobaloney
01-04-2012, 10:00 PM
Trying to update from CentOS 5.3; yum update returns this error:

Error: pkgKey 4157 doesn't exist in repo base
I tried the workarounds which come with the error message:

Error: pkgKey 4157 doesn't exist in repo base
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
Can't find anything with Google; anyone have any ideas for a workaround?

Jeff

zEitEr
01-05-2012, 01:06 AM
Never seen this error before. Try and disable all extra repos (such as epel, dag, forge, etc), and leave only base one. And check it again with yum

NoBaloney2
01-08-2012, 09:49 AM
No extra repos were ever added. Any other ideas?

Jeff

Richard G
01-08-2012, 06:05 PM
I found the following commands via Google you could ltry. Maybe you tried already, but it's not mentioned in your post so here they are:

yum clean all
and after that:

yum clean metadata

Hope it will do some good.

scsi
01-09-2012, 06:56 AM
oh greetings greetz greet gree

Richard G
01-09-2012, 08:15 AM
Is that a confirmation that it worked for you Scsi?

NoBaloney2
01-09-2012, 11:43 AM
I think SCSI runs FreeBSD, though I'm not sure.

But I can confirm that this fixes the problem for me.

Thanks, Richard!

Jeff

zEitEr
01-10-2012, 12:07 AM
@Richard G

I guess, it makes user scsi happy when he sees word "Greetings" and any forms of it anywhere here)))

@Jeff

That's good, you've managed to sort the things out.

NoBaloney2
01-10-2012, 08:24 AM
No, Richard G sorted it out; I just implemented it :) .

Jeff