PDA

View Full Version : Custombuild



keisko
05-11-2012, 05:08 AM
Hello,


Latest version of PHP (CLI): 5.3.13
Installed version of PHP (CLI): 5.3.10

PHP5 (CLI) 5.3.10 to 5.3.13 update is available.

phpinfo() function shows that my server has php 5.3.13..

Results of ./build update_versions

Make Complete
Copying php.ini..
/usr/local/lib/php.ini already exists, skipping.
Increasing memory limit to 32M...
Installing php...
Installing PHP SAPI module: apache2handler
/var/www/build/instdso.sh SH_LIBTOOL='/var/www/build/libtool' libphp5.la /usr/lib/apache
/var/www/build/libtool --mode=install install libphp5.la /usr/lib/apache/
libtool: install: install .libs/libphp5.so /usr/lib/apache/libphp5.so
libtool: install: install .libs/libphp5.lai /usr/lib/apache/libphp5.la
libtool: install: warning: remember to run `libtool --finish /usr/local/directadmin/custombuild/php-5.3.13/libs'
chmod 755 /usr/lib/apache/libphp5.so
apxs:Error: Activation failed for custom /etc/httpd/conf/httpd.conf file..
apxs:Error: At least one `LoadModule' directive already has to exist..
make: *** [install-sapi] Error 1
Stopping httpd: [ OK ]
Starting httpd:

What's wrong?

scsi
05-11-2012, 06:18 AM
Very strange ... you might need to run ./build rewrite_confs to fix all your apache configs. You might also need to try rebuilding apache and php.

keisko
06-16-2012, 04:17 PM
I did:
./build clean
./build update
./build rewrite_confs
./build all n

Doesn't help.

- php -v

php -v
Failed loading /usr/local/ioncube/ioncube_loader_lin_5.3.so: /usr/local/ioncube/ioncube_loader_lin_5.3.so: undefined symbol: compiler_globals
PHP 5.3.10 (cli) (built: Feb 27 2012 16:53:47)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies

scsi
06-18-2012, 06:29 AM
./build ioncube d