PDA

View Full Version : Frontpage problems at FreeBSD 5.x?



wdv
09-08-2004, 06:35 AM
Hey,

I discovered that frontpage isn't working in FreeBSD 5.x:

su-2.05b# /usr/local/frontpage/version5.0/bin/owsadm.exe
/usr/libexec/ld-elf.so.1: /usr/lib/libc_r.so.4: Undefined symbol "_flockfile"

I did install the 4.x compatibility package.

Any idea what's wrong?

wdv
09-08-2004, 03:21 PM
I found the solution:

Symlink /usr/lib/libc_r.so.4 to /usr/local/lib/compat/libc_r.so.4.compat4x and it works :)

nobaloney
09-08-2004, 09:34 PM
Great job, wdv.

Can you post this as a mini how-to in the how-to section?

Thanks.

Jeff

wdv
09-09-2004, 10:07 AM
Just posted the mini-howto:

http://www.directadmin.com/forum/showthread.php?s=&threadid=4770

Have fun with it :)

dan35
01-09-2005, 02:12 AM
Hi,

There isn't any libc_r.so.4.compat4x on Freebsd 5.3.

Thanks!

dan35
01-09-2005, 02:37 AM
Nevermind! I just installed compat4x :)

dan35
01-10-2005, 02:56 AM
Hi,

I don't know how to fix this:



log:

[error] [client myip xxx] (13)Permission denied: getgrgid: invalid groupid 1015
[Mon Jan 10 02:47:36 2005] [error] (13)Permission denied: exec of /usr/local/frontpage/version5.0/apache-fp/_vti_bin/fpexe failed
[Mon Jan 10 02:47:36 2005] [error] [client ip xx] Premature end of script headers: /usr/local/frontpage/version5.0/apache-fp/_vti_bin/fpexe


/etc/group
....
myname:*:1015:


#cd /usr/local/frontpage/version5.0/apache-fp/_vti_bin/
#ls -l
total 12
-rwsr-xr-x 1 root bin 11451 Jun 27 2003 fpexe

I can't connect to my site via frontpage.

dan35
01-10-2005, 03:05 AM
Damn! Stupid mistake!

just chmod 644 group (the old was 640)