PDA

View Full Version : zlib



GouroB
06-30-2005, 01:16 PM
Hi there , i am facing a weired problem for that i came here ... I use Unrealircd for my chat server , and my dedicated box which is running freebsd has Direct admin 1.24.3 , and whenever i am trying to install Unrealircd3.2.3 its giving me this error

[!!!] Zlib version mismatch: compiled for '1.2.2', library is '1.1.4' [!!!] Header<->library mismatches can make UnrealIRCd *CRASH*! Make sure you don't have multiple versions of openssl or zlib installed (eg: one in /usr and one in /usr/local). And, if you recently upgraded them, be sure to recompile Unreal.
I went to Unrealircd coders they told me this is becoz i have a old version of zlib , and unreal requires new version . so i asked the admin of the company from whom i baught the dedicated server and they said zlib is a part of direct admin , when they installs direct admin it also gets installed so now any idea what to do at this stage ?

jmstacey
06-30-2005, 07:44 PM
Customapache handles zlib and as far as I know it's the latest version (1.2.2) so I don't know where it's getting 1.2.4.

Do you have the zlib development package installed? And only one version of zlib, the one DirectAdmin installs and not one that might have come with your Operating System?
Have you tried specifying the path to the proper zlib library when configuring unrealircd?

GouroB
06-30-2005, 10:10 PM
Customapache handles zlib and as far as I know it's the latest version (1.2.2) so I don't know where it's getting 1.2.4.

Yes 1.2.2 is the latest version and i am getting error that my box has zlib version 1.1.4 which is old version ..... by the way what is the default path of zlib library .. with DA installed ( latest version ) ?

jmstacey
06-30-2005, 11:13 PM
I think it's just the default zlib location which is /usr/local/lib if I remember correctly.