Dovecot imap login authentication failled

Djunity

Verified User
Hi,

After 3 days of searching and testing i have no idea anymore what my issue could be.

This is whats been done and the issue is.

We migrated a reseller from a centos 5 server with latest directadmin and dovecot and exim and exim.conf spamblocker
The new server has the same setup latest directadmin and dovecot and exim.conf with spamblocker

All email accounts of all user account of this reseller now have issue's with login to there email accounts.
They keep getting Authentication failled errors when connection or trying to download the imap maps.

However when you enable ssl and go with port 993 for incomming email on the client there is no problem so only with normal connection over port 143 there is an issue.

The issue is also with webmail (roundcube squirrelmail etc)

ALL other email accounts on the server dont have this issue.

What am i missing we allready run scripts for file rights aka /usr/local/directadmin/scripts/set_permissions.sh user_homes email Maildir etc rebuilded majordomo dovecot and exim checked for existing /etc/virtual files and check if the password in /etc/virtual/domain.com/passwd is changing if you change the email address password from webinterface and it does.

What am i missing or nor seeing any one have an idea ? thanks in advance
 

smtalk

Verified User
Staff member
Make sure /etc/virtual/domain.com/passwd has a correct UID (User ID) set for each email (it should match the user ID from /etc/passwd).
 

smtalk

Verified User
Staff member
I could check it for you then (free of charge), but I'm not sure if I'd have enough of time today for it :)
 

Djunity

Verified User
Hi zEitEr,

Dns is correct domains point to new server.
As in mentioned in my first post if you turn on ssl for incomming email with port 993 it does work only normal connection over port 143 gives this issue.
 

zEitEr

Super Moderator
With wrong passwords you still should see something similar to the following:

Code:
Sep 16 07:57:29 shared dovecot[3641]: auth-worker(7313): shadow(userbob@domain.com,81.bbb.ccc.ddd): unknown user
Sep 16 07:57:29 shared dovecot[3641]: auth: passwd-file(userbob@domain.com,81.bbb.ccc.ddd,<UBxYPCQDaQBRyB+n>): Password mismatch
Sep 16 07:57:31 shared dovecot[3641]: pop3-login: Aborted login (auth failed, 1 attempts in 2 secs): user=<userbob@domain.com>, method=PLAIN, rip=81.bbb.ccc.ddd, lip=195.bbb.ccc.ddd, session=<UBxYPCQDaQBRyB+n>
Will this help you?

Code:
./build update
./build dovecot
./build todovecot
 

Djunity

Verified User
With wrong passwords you still should see something similar to the following:

Code:
Sep 16 07:57:29 shared dovecot[3641]: auth-worker(7313): shadow(userbob@domain.com,81.bbb.ccc.ddd): unknown user
Sep 16 07:57:29 shared dovecot[3641]: auth: passwd-file(userbob@domain.com,81.bbb.ccc.ddd,<UBxYPCQDaQBRyB+n>): Password mismatch
Sep 16 07:57:31 shared dovecot[3641]: pop3-login: Aborted login (auth failed, 1 attempts in 2 secs): user=<userbob@domain.com>, method=PLAIN, rip=81.bbb.ccc.ddd, lip=195.bbb.ccc.ddd, session=<UBxYPCQDaQBRyB+n>
Will this help you?

Code:
./build update
./build dovecot
./build todovecot
Hi alex

Try'd That yesterday no result

In The client "windows livemail outlook etc" You get error authentication failled check login name and password.
 
Top