Dovecot panic file lib-event.c: line 182 + service(lmtp) killed with signal 6

wattie

Verified User
I rebuilt practically everything. These errors are happening with both 2.3.1 and 2.3.2. They are from dovecot-lmtp-errors.log:

Panic: file lib-event.c: line 182 (event_pop_global): assertion failed: (event != NULL)
Also I get some of these in /var/log/messages which is even worse I guess:

dovecot[40214]: lmtp: Fatal: master: service(lmtp): child 52296 killed with signal 6 (core not dumped - https://dovecot.org/bugreport.html#coredumps - set service lmtp { drop_priv_before_exec=yes })
OS: FreeBSD
 

wattie

Verified User
It could be a followup of an Exim issue which is probably related to a SpamAssassin one. I am looking into it.

P.S. In the Exim paniclog once or twice per day I start getting first these:

spam acl condition: all spamd servers failed
then these:

Failed writing transport results to pipe: Broken pipe
which eventually results in Exim bouncing back e-mails. And the lmtp errors from above are appearing at the same time.

P.S. This seems to be related to sa-update as shown here: http://forum.directadmin.com/showthread.php?t=56583
It doesn't seem to be connected with the issue described above.
 
Last edited:

toml

Verified User
It might be only on FreeBSD. I don't have any of these issues on Centos 6.
I get similar errors on CentOS 6. This is what I see in the /var/log/maillog:
Code:
Jul  4 07:30:14 moe dovecot[23068]: lmtp: Fatal: master: service(lmtp): child 32101 killed with signal 6 (core dumps disabled - https://dovecot.org/bugreport.html#coredumps)
I found it to be caused by the setting in /etc/exim.conf for local_user router that has the transport set to:
transport = dovecot_lmtp_udp
when I change it to the old way:
transport = virtual_localdelivery
the errors go away completely.
 

Richard G

Verified User
I only checked the logs mentioned by wattie. Since your comment I checked the maillog too.
But I only see these lines in there:
Code:
Jul  4 01:25:41 server18 dovecot[21729]: master: Dovecot v2.3.2 (582970113) starting up for imap, pop3, lmtp (core dumps disabled)
Doesn't look like a problem or error notice.
However, i did not change anything in my exim.conf (spamblocker version 4.5.9) which still contains the line:
transport = local_delivery
under local_user.
I only have the "transport = dovecot_lmtp_udp" in the virtual user routers of exim.conf.

Could it be you are using an older exim.conf?
 
Last edited:

toml

Verified User
I wrote the wrong router in my reply, it was the virtual_user. I have the latest exim.conf (4.5.9), I personally changed mine from "transport = dovecot_lmtp_udp" to "transport = virtual_localdelivery" so that exim would add the email to the Maildir instead of calling dovecot's lmtp to do the delivery.

I don't have a lot of the error messages in my log file, about 7-8 per day. Reading some messages from the dovecot mailing list, I assumed it was due to a 40MB message limitation and that a fix was supposed to be integrated into the latest version. I changed it back to use the lmtp and started receiving those errors again, so I changed my transport back to virtual_localdelivery and stopped receiving the errors since.
 

Richard G

Verified User
Ah oke in that case I wonder why I don't have any issues while I still have the dovecot_lmtp_udp line in the virtual_user section. I'm curious now what can be causing this.
The only fatal error I had was yesterday about a version mismatch which dissappeared after restarting dovecot.

P.s. the other servers, also Centos 6.x with the same configuration also don't have any issues. However I don't have pigeonhole installed, don't know if that makes any difference.
 
Top