Error about GD

deserts

Verified User
Photo Watermark functional opened failures : the need to support PHP Translation gd jpeg freetype

Lack
FreeType Linkage:with freetype
 

deserts

Verified User
with da
http://yz01.5y6s.net/phpinfo.php

gd
GD Support enabled
GD Version bundled (2.0.28 compatible)
GIF Read Support enabled
GIF Create Support enabled
JPG Support enabled
PNG Support enabled
WBMP Support enabled
XBM Support enabled


wihtout da
http://www.5y6s.com/phpinfo.php

gd
GD Support enabled
GD Version bundled (2.0.28 compatible)
FreeType Support enabled
FreeType Linkage with freetype
T1Lib Support enabled

GIF Read Support enabled
GIF Create Support enabled
JPG Support enabled
PNG Support enabled
WBMP Support enabled
XBM Support enabled
 
Last edited:

nobaloney

NoBaloney Internet Svcs - In Memoriam †
I've merged the two threads of the same name by the same poster into one in the Beta Testing | FreeBSD 6.x forum, as FreeBSD 6.x support is still in beta.

Have you searched these forums? I remember seeing some recent posts about GD, and perhaps you can find some information in prior posts.

Jeff
 

Chrysalis

Verified User
this happens in DA for freebsd 4.x and 5.x as well.

I posted the fix in another thread but it involves in installing the gd port which will install freetype support and then changing the path to gd in configure.php and recompiling php.
 

ballyn

Verified User
DA specifically builds GD without freetype since not all machines have the freetype-devel stuff installed.

If you want to install php with freetype support in GD:

1) Make sure you have freetype and freetype-devel installed
2) Edit the build script, remove the "--without-freetype" from the configure command in the doGD function (around line 1042)
3) rebuild php, and choose yes when it asks you to rebuild GD
 

dennisc

Verified User
Code:
[COLOR=blue]cd /usr/ports/print/freetype ; make install clean
cd /usr/local/directadmin/customapache

vi build[/COLOR]
[COLOR=red]#./configure --with-png=/usr/local --with-jpeg=/usr/local --without-freetype --without-x
./configure --with-png=/usr/local --with-jpeg=/usr/local -with-freetype=/usr/local --without-x[/COLOR]

[COLOR=blue]vi configure.php_ap2[/COLOR]
[COLOR=red]--with-ttf=/usr/lib \
--enable-gd-native-ttf \
--with-freetype-dir=/usr/local/lib[/COLOR]

[COLOR=blue]./build clean ; ./build php_ap2 y[/COLOR]
Cheers!
 
Last edited:

TheBear

Verified User
dennisc said:
Code:
[COLOR=blue]cd /usr/ports/print/freetype ; make install clean
cd /usr/local/directadmin/customapache

vi build[/COLOR]
[COLOR=red]#./configure --with-png=/usr/local --with-jpeg=/usr/local --without-freetype --without-x
./configure --with-png=/usr/local --with-jpeg=/usr/local -with-freetype=/usr/local --without-x[/COLOR]

[COLOR=blue]vi configure.php_ap2[/COLOR]
[COLOR=red]--with-ttf=/usr/lib \
--enable-gd-native-ttf \
--with-freetype-dir=/usr/local/lib[/COLOR]

[COLOR=blue]./build clean ; ./build php_ap2 y[/COLOR]
Cheers!

I have tried these steps as well, and still get errors about zlib :(

checking for jpeg_read_header in -ljpeg... yes
configure: error: PNG support requires ZLIB. Use --with-zlib-dir=<DIR>
/usr/local/directadmin/customapache/configure.php: line 12: --with-kerberos: command not found

Any other suggestions?
 
Top