File not found on password screen?

Richard G

Verified User
File not found on password screen? Bug on new installs!

Just did a fresh install on a Centos 7 server, then restored an admin backup from a Centos 6 server.
Had to change the backup from admin.name.admin.tar.gz to admin.root.tar.gz otherwise it would not restore. But so far so good, after changing it restores without issues, I only have to change the password back from the old to the new.

So I want to change a password.
On admin and reseller panel "changes passwords" in the enhanced skin I see this:
filenotfound.png

Which file is not found ???

Then another question.
When going to userlevel, change pass, you can select to change the Directadmin account, main ftp account and "main database account."
I presume the "main database account" is only for admin, because the da_admin mysql pass is not change here, correct?
 
Last edited:

ditto

Verified User
I just tested on Enhanced on one of my servers, and on "Reseller Level" - "Change Password" it looks good, I do not get a "File not found" text like you did. So that is strange that you get this.

The other thing, if you log in "as a user" and then change password, I think it is best to select all three: "Directadmin account, main ftp account and main database account.", so that password is the same on all three and will not cause confusion in the future. Regarding "main database account.", it is so that you can log into phpMyAdmin with the same user name and password as the DirectAdmin account, so if you do not select "main database account.", then you have to remember you have the old password for that one. Yes, this does not change da_admin user password, only the "main database account" wich give access to all databases under that user in one login.
 

Richard G

Verified User
So that is strange that you get this.
Hmmz... I also found this strange.
I'm wondering if this could have anything to do with restoring the admin account to that server.

The problem is that if I use the original backup which is called admin.name.admin.tar.gz then an the restore will fail with the error that this user already exists under user admin. Which is not the case because it's a fresh install. :)

Anyway, I just tested by creating a new administrator. When loggin in as this administrator the File Not Found is also there.

I also think I found a bug on deleting users.
 

ditto

Verified User
Personally I never restore the admin user when I do server migrations, because I do not have any domains under the admin user. However if you do, then I understand you would want to restore the admin user also.
 

Richard G

Verified User
I only have 1 domain under the admin user, only used for nameservers, everything else is under other admins and resellers.
 

Richard G

Verified User
I can confirm this is a bug! Or rather skin issue.
Just did a branad new server installation. Then changing Evolution Skin to Enhanced skin. Did nothing else before doing this.
And again the File Not Found is back.
 
Top