Greylisting not working

iworx

Verified User
I've recently switched from SpamAssassin to RSPAMD and it works brilliantly well, except for the greylisting.
It is active and it shows soft reject / please try again in the message headers but Exim still allows it to be delivered.

I assume there is something in the config ACL's that accepts the mails but I can't seem to figure out why/where.

Did anyone solve this question?
 

smtalk

Administrator
Staff member
Please try editing /etc/exim/rspamd/check_message.conf and uncommenting these lines:
Code:
#defer message    = Please try again later
#    condition  = ${if eq{$spam_action}{soft reject}}

We may uncomment them by default in the next release.
 

iworx

Verified User
Thanks - but they aren't commented out.

# use greylisting available in rspamd v1.3+
defer condition = ${if eq{$acl_m_rspamd_on}{1}}
message = Try again later
condition = ${if eq{$spam_action}{soft reject}}
 

smtalk

Administrator
Staff member
Please try changing last condition line to:
Code:
condition  = ${if eq{$spam_action}{greylist}}
Also, make sure /etc/rspamd/local.d/settings.conf exists on the system, it should have this inside:
Code:
.include "$CONFDIR/directadmin-users.conf"
There was also another issue noticed, already fixed, but not on all servers, so, you may also want to apply:
Code:
perl -pi -e 's|acl_m_esf_skip|acl_c_esf_skip|g' /etc/exim/rspamd/check_message.conf
perl -pi -e 's|acl_m_rspamd\}|acl_c_rspamd}|g' /etc/exim/rspamd/check_message.conf
perl -pi -e 's|acl_m_rspamd\}|acl_c_rspamd}|g' /etc/exim.easy_spam_fighter/check_message.conf
perl -pi -e 's|acl_m_esf_skip|acl_c_esf_skip|g' /etc/exim.easy_spam_fighter/check_message.conf
perl -pi -e 's|acl_m_rspamd|acl_c_rspamd|g' /etc/exim/rspamd/connect.conf
perl -pi -e 's|acl_m_rspamd|acl_c_rspamd|g'  /etc/exim.easy_spam_fighter/connect.conf
perl -pi -e 's|acl_m_esf_skip|acl_c_esf_skip|g' /etc/exim.easy_spam_fighter/connect.conf
If something still has issues - just let us know :) Thank you!
 
Last edited:

iworx

Verified User
I have to comment out the spamassassin lines in /etc/exim.easy_spam_fighter/check_message.conf because otherwise it runs twice through rspamd resulting in duplicate lines in the logs.

If I create the /etc/rspamd/local.d/settings.conf file - it only scans mails for those that have 'touched' the spamassassin settings - I want this to be active for all users.
 
Last edited:

smtalk

Administrator
Staff member
Did you apply perl commands mentioned above and it is still happening? (checks twice)
 

iworx

Verified User
Yes. I think it's related to this : ${if !eq{$acl_m_rspamd}{1}} - this gives me issues along the way.
 

iworx

Verified User
I think I need to redo the setup. Is there an easy way to restore the config files back to their original state? It works now - with all the modifications but I'm worried it will break after a next update.
 
Top