[PLUGIN] CustomBuild 2.0

smtalk

Verified User
Staff member
Hello,

Finally I have something to show for you guys! :) I have tried it to make as good as possible. Please let me know your feedback, feature requests, bugs etc.

Download link: http://www.custombuild.eu/plugin/custombuild.tar.gz

NOTE: CustomBuild 2.0 is needed for plugin to work.

1.png 2.png 3.png 4.png
I am attaching some screenshots too.
Thank you all for creating feature requests on the forums and your tries to improve DirectAdmin! :)
 
Last edited:

Active8

Verified User
Just installed withoud problems, but:

1.Please use another colors, it difficult to see if something is on or off (use green red or so)
2.Template is much wider than the enhanced skin, i think few bugs in the css
 

smtalk

Verified User
Staff member
Active8, what is your skin? May you remove the plugin, install it again and attach a screenshot? Thank you for your opinion about the colors!
 

smtalk

Verified User
Staff member
Yes, I see that the plugin is wider with enhanced. Thank you for the report, I'll review that soon and will release version 1.0.1 of the plugin. You'll see the update in your plugin manager, and I'll let you know about it here :)
 

smtalk

Verified User
Staff member
I have not tested it on Windows browsers (just OS X and Linux), thank you for the 2nd report, that's CSS related and I'll try reviewing that in a virtual MS Windows environment.
 

Arieh

Verified User
I'm getting the foreach error and tried the gcc line; however I'm still getting a foreach error, anything I can check or do?

Edit; I've put print $defaultParams; edit_options.php to see why it can't read it;

It outputs as follows:

-e "php_settings": {
-e "description": "PHP Settings",
-e "php1_release": {
-e "values": ["5.3","
I think that -e in front of each line shouldn't be there.
 
Last edited:

smtalk

Verified User
Staff member
Please post me the output of:
Code:
ls -l /usr/local/directadmin/plugins/custombuild/admin/build
gcc -std=gnu99 -B/usr/bin -o /usr/local/directadmin/plugins/custombuild/admin/build /usr/local/directadmin/plugins/custombuild/admin/build.c && chown root:admin /usr/local/directadmin/plugins/custombuild/admin/build && chmod 4755 /usr/local/directadmin/plugins/custombuild/admin/build
ls -l /usr/local/directadmin/plugins/custombuild/admin/build
Also, what is your OS?
 

Arieh

Verified User
Please post me the output of:
Code:
ls -l /usr/local/directadmin/plugins/custombuild/admin/build
gcc -std=gnu99 -B/usr/bin -o /usr/local/directadmin/plugins/custombuild/admin/build /usr/local/directadmin/plugins/custombuild/admin/build.c && chown root:admin /usr/local/directadmin/plugins/custombuild/admin/build && chmod 4755 /usr/local/directadmin/plugins/custombuild/admin/build
ls -l /usr/local/directadmin/plugins/custombuild/admin/build
Also, what is your OS?
Debian 7

Code:
root@server:/usr/local/directadmin/custombuild# ls -l /usr/local/directadmin/plugins/custombuild/admin/build
-rwsr-xr-x 1 root admin 12164 May 18 00:20 /usr/local/directadmin/plugins/custombuild/admin/build
root@server:/usr/local/directadmin/custombuild# gcc -std=gnu99 -B/usr/bin -o /usr/local/directadmin/plugins/custombuild/admin/build /usr/local/directadmin/plugins/custombuild/admin/build.c && chown root:admin /usr/local/directadmin/plugins/custombuild/admin/build && chmod 4755 /usr/local/directadmin/plugins/custombuild/admin/build
root@server:/usr/local/directadmin/custombuild# ls -l /usr/local/directadmin/plugins/custombuild/admin/build
-rwsr-xr-x 1 root admin 12164 May 18 00:31 /usr/local/directadmin/plugins/custombuild/admin/build
(also see my edit in prevrious post)
 

SeLLeRoNe

Super Moderator
Hi smtalk,

it does work for me, i'll test deeply as soon as possible but i've just notice something,

the fileserver 11 is not present in the list

Regards and thanks for this plugin :)
 

smtalk

Verified User
Staff member
CSS-related problems should now be fixed on enhanced skin. May you try to update to 1.0.1?
 

smtalk

Verified User
Staff member
I'm getting the foreach error and tried the gcc line; however I'm still getting a foreach error, anything I can check or do?

Edit; I've put print $defaultParams; edit_options.php to see why it can't read it;

It outputs as follows:



I think that -e in front of each line shouldn't be there.
Thank you for this! :) That cannot be changed in the CustomBuild plugin, but I will fix that in the CustomBuild script tomorrow. It seems that "echo" shows "-e" for some reason on your system when printing the lines.
 

smtalk

Verified User
Staff member
Hi smtalk,

it does work for me, i'll test deeply as soon as possible but i've just notice something,

the fileserver 11 is not present in the list

Regards and thanks for this plugin :)
Thank you for the report. That is John who created the list of servers (http://files.directadmin.com/services/custombuild/servers.txt), files11 is not there, so you may want to ask him about it. When it gets added to servers.txt, the plugin should show it immediately after "./build update".
 

smtalk

Verified User
Staff member
1.Please use another colors, it difficult to see if something is on or off (use green red or so)
Selected "button" is now in dark blue in 1.0.2 version of the CustomBuild plugin. Also, I was unable to find any other bugs with enhanced skin :)
 

smtalk

Verified User
Staff member
I like this plugin very much!

The options page is a little bit complex.
I'm happy to hear that! :) Have you seen the tooltips? If you have an idea about how to improve it, please let me know, but I wanted to leave it like the options.conf "editor" :)
 
Top