Solve DirectAdmin invalid SSL error on login page using LetsEncrypt

mbsmt

Verified User
Hi everybody.
As you know, by enabling SSL for DA login page, we get invalid SSL error. Is there any way to use SSL issued by LetsEncrypt on DirectAdmin to solve this problem? Does DA let us to do something like this?
 

Active8

Verified User
Please check http://help.directadmin.com/item.php?id=15 (Part: Using the free "Let's Encrypt" tool to secure 2222).
Ok , what will be happens when a user try to login via his website ? example

server.server.com:2222 works because we generate a certificate for the server name this works but what will be happens if the user wants to login as user website.com:2222 ? will it be automatically forwarded to server.server.com:2222 ?
 

MauriceO

Verified User
I got the following error when following the step for Using the free "Let's Encrypt" tool to secure 2222 on http://help.directadmin.com/item.php?id=15:

> ./letsencrypt.sh request <host> 4096
Setting up certificate for a hostname: <host>
Getting challenge for <host> from acme-server...
User let's encrypt key has been found, but not registered. Registering...
Account registration error. Response: HTTP/1.1 100 Continue
Expires: Mon, 27 Jun 2016 16:02:19 GMT
Cache-Control: max-age=0, no-cache, no-store
Pragma: no-cache

HTTP/1.1 400 Bad Request
Server: nginx
Content-Type: application/problem+json
Content-Length: 144
Boulder-Request-Id: nUZaDe9YR1QtNImi459vEoRcwrbRZV6WBRjlMqKx-QU
Replay-Nonce: VU4rTmLXSJULXwc3bAtzW4BnSCXCQXEohPkh6yjfcCA
Expires: Mon, 27 Jun 2016 16:02:19 GMT
Cache-Control: max-age=0, no-cache, no-store
Pragma: no-cache
Date: Mon, 27 Jun 2016 16:02:19 GMT
Connection: close

{
"type": "urn:acme:error:invalidEmail",
"detail": "DNS problem: NXDOMAIN looking up MX for <host>",
"status": 400
}.
 

SevereNL

New member
Since yesterday we have a sort alike problem.
On all our DirectAdmin servers we encounter the following problem
(while it was working two days ago, no changes to the servers have been made)
DirectAdmin version: 1.50.1
OS: CentOS 7.0 64Bit

What is see is: Last Updated Mon Aug 1 05:07:02 2016 under license values

Cannot Execute Your Request

Details

Getting challenge for <domain> from acme-server...
User let's encrypt key has been found, but not registered. Registering...
Account registration error. Response: HTTP/1.1 100 Continue
Expires: Wed, 03 Aug 2016 08:57:02 GMT
Cache-Control: max-age=0, no-cache, no-store
Pragma: no-cache

HTTP/1.1 400 Bad Request
Server: nginx
Content-Type: application/problem+json
Content-Length: 265
Boulder-Request-Id: soEpYUO5WO657F4ie9A0Q3yt7POMZwmP7JNYSf3cqQg
Replay-Nonce: OyWxmSh1HmVogVLCYVB-yeNx5sajoeK1T8tw8ekPuRY
Expires: Wed, 03 Aug 2016 08:57:03 GMT
Cache-Control: max-age=0, no-cache, no-store
Pragma: no-cache
Date: Wed, 03 Aug 2016 08:57:03 GMT
Connection: close
{
"type": "urn:acme:error:malformed",
"detail": "Provided agreement URL [https://letsencrypt.org/documents/LE-SA-v1.0.1-July-27-2015.pdf] does not match current agreement URL [https://letsencrypt.org/documents/LE-SA-v1.1.1-August-1-2016.pdf]",
"status": 400
}.
 
Top