Recent content by Peter Laws

  1. Peter Laws

    MySql 5.5 to 5.7

    This has no doubt come up before. Can we go from 5.5 straight to 5.7, or do we need to go from 5.5 to 5.6, then to 5.7?
  2. Peter Laws

    OpenSSL two versions

    Changing mirror then ./build clean and ./build update_data fixed it <shrug emoji> Dodgy mirrors?! (was set to 'files-fr.' fwiw) And removing (purge) apache2-dev then rebuilding fixed php compiles.
  3. Peter Laws

    OpenSSL two versions

    # dpkg --get-selections | grep apache apache2-dev install Can't really recall why I needed to install the dev package. Back to this OpenSSL thing, I forgot, Exim also failed to compile mentioning SSL stuff cc -DMACRO_PREDEF tls.c cc -DMACRO_PREDEF transports/appendfile.c tls.c:23:3...
  4. Peter Laws

    OpenSSL two versions

    Now, all I need is to work out why this is happening on another system..... Why looking for apache2 directory instead of httpd? Installing php... Installing PHP SAPI module: apache2handler /usr/share/apache2/build/instdso.sh SH_LIBTOOL='/var/www/build/libtool' libphp7.la...
  5. Peter Laws

    OpenSSL two versions

    That worked....... Looks like Curl has http/2 naitively since 7.50?
  6. Peter Laws

    OpenSSL two versions

    only for apache, curl (both for this http/2 feature), and proftpd (for mod_sftp)
  7. Peter Laws

    OpenSSL two versions

    Returns nothing at all.
  8. Peter Laws

    OpenSSL two versions

    Ok, in that case what, would be the reason why PHP (no matter what version) fails stating something about OpenSSL stuff? See this Pastebin
  9. Peter Laws

    OpenSSL two versions

    By the way, I followed this https://forum.directadmin.com/threads/how-to-enable-http-2-in-apache-nginx-curl.52590/ for debian 8 down
  10. Peter Laws

    OpenSSL two versions

    I think it was because of http2 support prior to CB native support...... openssl version, gives 1.0.01. And I see a 1.0.2q in /root/
  11. Peter Laws

    cmake & curl

    It wasn't but it was the problem....
  12. Peter Laws

    cmake & curl

    Now I get a new error (Debian 8) As for tickets, I thought OWNED licenses only got 12 months support? I have used tickets before, surprisingly.
  13. Peter Laws

    cmake & curl

    This is why I essentially stopped visiting here, questions go unanswered.....
  14. Peter Laws

    cmake & curl

    When installing php 7.4, the pre-install of libzip: cmake: /usr/local/lib/libcurl.so.4: no version information available (required by cmake) Fix it by ln -fs /usr/lib/libcurl.so.4 /usr/local/lib/ but CB gives there's an cURL update from 0 to blah How to fix this?
Top