i was having this issue but it's working fine for me now so you should be fine to upgrade.