Search results

  1. W

    Dovecot 2.3.9 build error

    FreeBSD 11.3 here. I get the following error when building Dovecot: ... net.c:1071:5: error: use of undeclared identifier 'EAI_ADDRFAMILY' { EAI_ADDRFAMILY, NET_HOSTERROR_TYPE_NOT_FOUND }, ^ net.c:1077:5: error: use of undeclared identifier 'EAI_NODATA'...
  2. W

    PHP 7.4 PECL?

    P.S. PEAR is considered outdated. It has lots of issues: 1. It install extensions only globally; 2. There is no dependency management; 3. All packages must be "pear reviewed" (the devs of extensions must always wait to be approved before pushing an update). Most of the developers migrated to...
  3. W

    PHP 7.4 PECL?

    In January this year there was a big hack on the pear website (the main installation package was replaced with malicious version with a trojan planted inside). That is not the reason but it triggered a discussion around it. PEAR is not actively maintained and even updates for deprecation...
  4. W

    PHP 7.4 PECL?

    PEAR is disabled by default on PHP 7.4. As "PECL is a repository of PHP extensions that are made available to you via the PEAR packaging system", it also removes the PECL too. To enable PEAR (and PECL) you need to add "--with-pear" in the configure script and recompile PHP 7.4. Here is the...
  5. W

    Need help with opcache

    Do this test: 1. Disable opcache and watch your "top" to see how much MB of RAM each php-fpm process takes 2. Enable it and do the same You will be surprised :)
  6. W

    PHP 7.4 installation error

    Yes, that was it. On FreeBSD you need to have /usr/ports/security/krb5 installed.
  7. W

    PHP 7.4 installation error

    configure: error: Package requirements (krb5-gssapi krb5) were not met: Package 'krb5-gssapi', required by 'virtual:world', not found Package 'krb5', required by 'virtual:world', not found Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard...
  8. W

    ClamAV 0.102.0

    On FreeBSD 11 I get this: /usr/bin/ld: warning: libssl.so.9, needed by ../libclamav/.libs/libclamav.so, may conflict with libssl.so.8 /usr/bin/ld: warning: libcrypto.so.9, needed by ../libclamav/.libs/libclamav.so, may conflict with libcrypto.so.8 ../libclamav/.libs/libclamav.so: undefined...
  9. W

    [SOLVED] WordPress Asking for FTP Credentials” Error?

    In future you can just use chmod -R for that.
  10. W

    MySQL utf8 issue

    You need to use utf8_bin collation on that column.
  11. W

    New Directadmin forum

    Much better
  12. W

    MariaDB 10.4.10

    There are some bugfixes plus two security patches - CVE-2019-2974 and CVE-2019-2938.
  13. W

    Php 7.3.11, 7.2.24 & 7.1.33

    All of them contain a security fix - CVE-2019-11043 More details about it: https://bugs.php.net/bug.php?id=78599 It is very important to upgrade especially if you are running Nginx.
  14. W

    ProFTPd 1.3.6b

    + Fixed pre-authentication remote denial-of-service issue (Issue #846). + Backported fix for building mod_sql_mysql using MySQL 8 (Issue #824).
  15. W

    Bind 9.14.7

    The newest version of Bind includes three security fixes: • A race condition could trigger an assertion failure when a large number of incoming packets were being rejected. This flaw is disclosed in CVE-2019-6471. [GL #942] • named could crash with an assertion failure if a forwarder returned...
  16. W

    Strange error at the end of the build on FreeBSD

    When I updated Dovecot to it's newest version today I got the following error at the end: Restarting dovecot. Stopping dovecot: cat: /var/run/dovecot/master.pid: No such file or directory usage: kill [-s signal_name] pid ... kill -l [exit_status] kill -signal_name pid ...
  17. W

    Bind 9.14.6

    This is a security and new features release for the Bind DNS server. The security one is a potential DoS attack: More information on it here: https://kb.isc.org/docs/cve-2019-6471 Full release notes here: https://downloads.isc.org/isc/bind9/9.14.6/RELEASE-NOTES-bind-9.14.6.html
  18. W

    OpenSSL 1.0.2t, 1.1.0l and 1.1.1d

    They fix CVE-2019-1547, CVE-2019-1549 and CVE-2019-1563 - three LOW severity security issues which are very unlikely to affect you at all. Still it is no bad if you update.
  19. W

    Can't find which user/process is doing login attempts

    I am on MariaDB 10.4, but this is a long running issue from a very long time ago. Every day in intervals between few minutes I see these entries in the BruteForce Monitor: 15676386600000 localhost 1 mysql1 2019-09-05 2:10:24 72774529 [Warning] Access denied for user ''@'localhost' (using...
Top