Page 1 of 2 12 LastLast
Results 1 to 20 of 22

Thread: ProFTPd 1.3.2rc1 Released!

  1. #1
    Join Date
    Aug 2007
    Location
    Kazakhstan, Almaty
    Posts
    58

    Thumbs up ProFTPd 1.3.2rc1 Released!

    ProFTPd 1.3.2rc1 has many new features

    RN:
    http://proftpd.org/docs/RELEASE_NOTES-1.3.2rc1

  2. #2
    Join Date
    Oct 2006
    Posts
    34
    Another new release this is getting ridiculous! How do I update on custombuild?

    Thanks.

  3. #3
    Join Date
    May 2008
    Posts
    23
    How do I update on custombuild?

  4. #4
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    7,485
    Code:
    cd /usr/local/directadmin/custombuild
    ./build update
    wget ftp://ftp.proftpd.org/distrib/source/proftpd-1.3.2rc1.tar.gz
    perl -pi -e 's#proftpd:1.3.1:3eab497e5d3a50ff012cac6759127cf8#proftpd:1.3.2rc1:e017918f5dcbb58b1de159a162fc796a#' versions.txt
    ./build proftpd
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  5. #5
    Join Date
    May 2008
    Posts
    23
    Code:
    test -z """" || (cd locale/ && make install)
    Done proftpd.
    Restarting ProFTPd.
    Stopping ftp server: proftpd.
    Starting ftp server: proftpd - Fatal: UseIPv6: Use of the UseIPv6 directive requires IPv6 support (--enable-ipv6) on line 14 of '/etc/proftpd.conf'
     failed!
    ks355985:/usr/local/directadmin/custombuild#

  6. #6
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    7,485
    Remove line 14 from /etc/proftpd.conf or add "--enable-ipv6 \" to /usr/local/directadmin/custombuild/configure/proftpd/configure.proftpd file and run "./build proftpd" again. If you want to save that new "configure.proftpd" file and use it with every proftpd update, do:
    Code:
    mkdir -p /usr/local/directadmin/custombuild/custom/proftpd
    cp -Rp /usr/local/directadmin/custombuild/configure/proftpd/configure.proftpd /usr/local/directadmin/custombuild/custom/proftpd/
    Good luck!
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  7. #7
    Join Date
    May 2008
    Posts
    23
    Quote Originally Posted by smtalk View Post
    Remove line 14 from /etc/proftpd.conf
    work fine

    Quote Originally Posted by smtalk View Post
    or add "--enable-ipv6 \" to /usr/local/directadmin/custombuild/configure/proftpd/configure.proftpd file and run "./build proftpd" again. If you want to save that new "configure.proftpd" file and use it with every proftpd update, do:
    Code:
    mkdir -p /usr/local/directadmin/custombuild/custom/proftpd
    cp -Rp /usr/local/directadmin/custombuild/configure/proftpd/configure.proftpd /usr/local/directadmin/custombuild/custom/proftpd/
    [...]
    not work?


    Thx.


  8. #8
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    7,485
    What's wrong with the 2nd suggestion?
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  9. #9
    Join Date
    May 2008
    Posts
    23
    I don't now.

    in /usr/local/directadmin/custombuild/configure/proftpd/configure.proftpd

    Code:
    #!/bin/sh
    install_user=ftp \
    install_group=ftp \
    ./configure \
    --prefix=/usr \
    --sysconfdir=/etc \
    --localstatedir=/var/run \
    --mandir=/usr/share/man \
    --without-pam \
    --disable-auth-pam \
    --with-modules=mod_ratio:mod_readme:mod_tls \
    --enable-ipv6 \
    LDFLAGS=-static
    and generate same error, but 1st suggestion work

  10. #10
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    7,485
    You need to do "./build proftpd" if you want to rebuild it.
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  11. #11
    Join Date
    May 2008
    Posts
    23
    Yes! And end of compilation I see:
    Starting ftp server: proftpd - Fatal: UseIPv6: Use of the UseIPv6 directive requires IPv6 support (--enable-ipv6) on line 14 of '/etc/proftpd.conf'
    failed!

  12. #12
    Join Date
    Apr 2004
    Posts
    59
    Error I am getting:

    Code:
    gcc -DHAVE_CONFIG_H  -DLINUX  -I.. -I../include  -O2 -Wall -c mod_tls.c
    In file included from /usr/include/openssl/ssl.h:179,
                     from mod_tls.c:40:
    /usr/include/openssl/kssl.h:72:18: krb5.h: No such file or directory
    In file included from /usr/include/openssl/ssl.h:179,
                     from mod_tls.c:40:
    /usr/include/openssl/kssl.h:134: syntax error before "krb5_enctype"
    /usr/include/openssl/kssl.h:136: syntax error before '*' token
    /usr/include/openssl/kssl.h:137: syntax error before '}' token
    /usr/include/openssl/kssl.h:149: syntax error before "kssl_ctx_setstring"
    /usr/include/openssl/kssl.h:149: syntax error before '*' token
    /usr/include/openssl/kssl.h:150: syntax error before '*' token
    /usr/include/openssl/kssl.h:151: syntax error before '*' token
    /usr/include/openssl/kssl.h:151: syntax error before '*' token
    /usr/include/openssl/kssl.h:152: syntax error before '*' token
    /usr/include/openssl/kssl.h:153: syntax error before "kssl_ctx_setprinc"
    /usr/include/openssl/kssl.h:153: syntax error before '*' token
    /usr/include/openssl/kssl.h:155: syntax error before "kssl_cget_tkt"
    /usr/include/openssl/kssl.h:155: syntax error before '*' token
    /usr/include/openssl/kssl.h:157: syntax error before "kssl_sget_tkt"
    /usr/include/openssl/kssl.h:157: syntax error before '*' token
    /usr/include/openssl/kssl.h:159: syntax error before "kssl_ctx_setkey"
    /usr/include/openssl/kssl.h:159: syntax error before '*' token
    /usr/include/openssl/kssl.h:161: syntax error before "context"
    /usr/include/openssl/kssl.h:162: syntax error before "kssl_build_principal_2"
    /usr/include/openssl/kssl.h:162: syntax error before "context"
    /usr/include/openssl/kssl.h:165: syntax error before "kssl_validate_times"
    /usr/include/openssl/kssl.h:165: syntax error before "atime"
    /usr/include/openssl/kssl.h:167: syntax error before "kssl_check_authent"
    /usr/include/openssl/kssl.h:167: syntax error before '*' token
    /usr/include/openssl/kssl.h:169: syntax error before "enctype"
    In file included from mod_tls.c:40:
    /usr/include/openssl/ssl.h:909: syntax error before "KSSL_CTX"
    /usr/include/openssl/ssl.h:931: syntax error before '}' token
    make[1]: *** [mod_tls.o] Error 1
    Obviously I am missing a header file
    Sean Finkel
    Owner | Protollix, LLC
    http://www.protollix.com

  13. #13
    Join Date
    Sep 2006
    Posts
    27
    When I try to update, the process appears to be successful, yet after restart proftpd, it still starts the old 1.3.0 version, not the 1.3.1 or 1.3.2rc1 that I have tried to install.

    This is a FreeBSD 6.2 server. Any ideas?

  14. #14
    Join Date
    Mar 2006
    Posts
    123
    Don't be so darned quick to update to new versions. Unless this version closes some huge security hole, realize that it is a release candidate and not the final version.

    If you are running a production box, only run production (stable-release) versions, not bleeding edge release candidates.

  15. #15
    Join Date
    Sep 2006
    Posts
    27
    Thanks, but I need to update for TLS support, which doesn't seem to be included in 1.3.0.

  16. #16
    Join Date
    May 2008
    Posts
    23

    Question



    Trying to make ProFTPD...
    cd lib/ && make lib
    make[1]: Wejście do katalogu `/usr/local/directadmin/custombuild/proftpd-1.3.2rc1/lib'
    make[1]: Nie ma nic do zrobienia w `lib'.
    make[1]: Opuszczenie katalogu `/usr/local/directadmin/custombuild/proftpd-1.3.2rc1/lib'
    cd src/ && make src
    make[1]: Wejście do katalogu `/usr/local/directadmin/custombuild/proftpd-1.3.2rc1/src'
    make[1]: Nie ma nic do zrobienia w `src'.
    make[1]: Opuszczenie katalogu `/usr/local/directadmin/custombuild/proftpd-1.3.2rc1/src'
    cd modules/ && make static
    make[1]: Wejście do katalogu `/usr/local/directadmin/custombuild/proftpd-1.3.2rc1/modules'
    gcc -DHAVE_CONFIG_H -DLINUX -I.. -I../include -O2 -Wall -Wno-long-double -c mod_tls.c
    mod_tls.c: W funkcji `tls_verify_ocsp,:
    mod_tls.c:3687: ostrzeżenie: docelowe typy wskaźnika przekazywanego jako argument 2 do funkcji `pstrdup, róźnią sie znakiem
    Na najwyższym poziomie:
    cc1: błąd: unrecognized command line option "-Wno-long-double"
    make[1]: *** [mod_tls.o] Błąd 1
    make[1]: Opuszczenie katalogu `/usr/local/directadmin/custombuild/proftpd-1.3.2rc1/modules'
    make: *** [modules] Błąd 2

    *** The make has failed, do you want to try to make again? (y,n):

  17. #17
    nobaloney's Avatar
    nobaloney is offline NoBaloney Internet Svcs - In Memoriam †
    Join Date
    Jun 2003
    Location
    California
    Posts
    26,122
    Polish error messages? Either you'll have to tell us what they mean, or hopefully someone who speaks the language will be able to reply.

    Jeff
    +1 951 643-5345
    Third-Party DirectAdmin administration and support
    Dedicated Servers, Dedicated Reseller Accounts
    NoBaloney Internet Services div. Qnito Incorporated
    848 North Rainbow Blvd., Suite #3789
    Las Vegas, NV 89107-1103

  18. #18
    Join Date
    Aug 2008
    Posts
    6
    Quote Originally Posted by Protollix View Post
    Error I am getting:

    Code:
    gcc -DHAVE_CONFIG_H  -DLINUX  -I.. -I../include  -O2 -Wall -c mod_tls.c
    In file included from /usr/include/openssl/ssl.h:179,
                     from mod_tls.c:40:
    /usr/include/openssl/kssl.h:72:18: krb5.h: No such file or directory
    In file included from /usr/include/openssl/ssl.h:179,
                     from mod_tls.c:40:
    /usr/include/openssl/kssl.h:134: syntax error before "krb5_enctype"
    /usr/include/openssl/kssl.h:136: syntax error before '*' token
    /usr/include/openssl/kssl.h:137: syntax error before '}' token
    /usr/include/openssl/kssl.h:149: syntax error before "kssl_ctx_setstring"
    /usr/include/openssl/kssl.h:149: syntax error before '*' token
    /usr/include/openssl/kssl.h:150: syntax error before '*' token
    /usr/include/openssl/kssl.h:151: syntax error before '*' token
    /usr/include/openssl/kssl.h:151: syntax error before '*' token
    /usr/include/openssl/kssl.h:152: syntax error before '*' token
    /usr/include/openssl/kssl.h:153: syntax error before "kssl_ctx_setprinc"
    /usr/include/openssl/kssl.h:153: syntax error before '*' token
    /usr/include/openssl/kssl.h:155: syntax error before "kssl_cget_tkt"
    /usr/include/openssl/kssl.h:155: syntax error before '*' token
    /usr/include/openssl/kssl.h:157: syntax error before "kssl_sget_tkt"
    /usr/include/openssl/kssl.h:157: syntax error before '*' token
    /usr/include/openssl/kssl.h:159: syntax error before "kssl_ctx_setkey"
    /usr/include/openssl/kssl.h:159: syntax error before '*' token
    /usr/include/openssl/kssl.h:161: syntax error before "context"
    /usr/include/openssl/kssl.h:162: syntax error before "kssl_build_principal_2"
    /usr/include/openssl/kssl.h:162: syntax error before "context"
    /usr/include/openssl/kssl.h:165: syntax error before "kssl_validate_times"
    /usr/include/openssl/kssl.h:165: syntax error before "atime"
    /usr/include/openssl/kssl.h:167: syntax error before "kssl_check_authent"
    /usr/include/openssl/kssl.h:167: syntax error before '*' token
    /usr/include/openssl/kssl.h:169: syntax error before "enctype"
    In file included from mod_tls.c:40:
    /usr/include/openssl/ssl.h:909: syntax error before "KSSL_CTX"
    /usr/include/openssl/ssl.h:931: syntax error before '}' token
    make[1]: *** [mod_tls.o] Error 1
    Obviously I am missing a header file
    Just for other people that might get this error:

    Solution:
    --------
    1. Make sure you have the krb5-devel and krb5-libs rpms installed.
    2. Create Symlink for the following files as follows:
    ln -s /usr/kerberos/include/com_err.h /usr/include/
    ln -s /usr/kerberos/include/profile.h /usr/include/
    ln -s /usr/kerberos/include/krb5.h /usr/include/

  19. #19
    Join Date
    May 2008
    Posts
    23
    I cant login on ftp :|
    Code:
    Apache 2.2.9	Running
    DirectAdmin 	Running
    Exim 4.67	Running
    MySQL 5.0.67	Running
    Named 9.3.4	Running
    ProFTPd 1.3.2rc1 	Running
    sshd 	Running
    dovecot 1.1.3 	Running
    Code:
    directadmin	directadmin (pid 3191 26734 26738 26844 26857 26913 )	Start	Stop	Restart	Reload
    dovecot	dovecot (pid 3196 )	Start	Stop	Restart	Reload
    exim	exim (pid 3201 )	Start	Stop	Restart	Reload
    httpd	httpd (pid 3245 3324 3326 3327 3328 3329 5451 5452 5453 )	Start	Stop	Restart	Reload
    mysqld	mysqld (pid 3293 )	Start	Stop		
    named	named (pid 3169 )	Start	Stop	Restart	Reload
    proftpd	proftpd (pid 26184 )	Start	Stop	Restart	
    sshd	sshd (pid 3300 )	Start	Stop	Restart	Reload
    but can't... Any ideas?
    Log & pass is 100% correct !!


    auth.log -> Unable to read log
    access.log -> Unable to read log

  20. #20
    Join Date
    Jul 2008
    Posts
    22

    Never ending proftpd issues

    Sorry for hijacking the topic. I've merged my post.
    Last edited by FishStick; 12-02-2008 at 11:43 AM.

Page 1 of 2 12 LastLast

Similar Threads

  1. ProFTPD 1.3.4b released
    By Arieh in forum Required Software Version Updates
    Replies: 35
    Last Post: 08-20-2012, 12:59 AM
  2. [ProFTPD-announce] ProFTPD 1.3.3a released!
    By Meesterlijk in forum Required Software Version Updates
    Replies: 3
    Last Post: 07-11-2010, 01:40 AM
  3. [ProFTPD-announce] ProFTPD 1.3.2c released
    By Meesterlijk in forum Required Software Version Updates
    Replies: 1
    Last Post: 12-17-2009, 02:55 PM
  4. ProFTPD 1.3.2 released!
    By Meesterlijk in forum Required Software Version Updates
    Replies: 15
    Last Post: 11-06-2009, 04:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •