Results 1 to 5 of 5

Thread: Debian Etch

  1. #1
    Join Date
    Jun 2007
    Posts
    10

    Debian Etch

    hia, getting the following error after a while while trying to use custombuild to upgrade to php5 apache2 mysql5:

    used:
    Code:
    cd /usr/local/directadmin
    wget http://files.directadmin.com/service...ombuild.tar.gz
    tar xvzf custombuild.tar.gz
    cd custombuild
    ./build update_data
    ./build all d
    error:
    Code:
    make[1]: Entering directory `/usr/local/directadmin/custombuild/mhash-0.9.9/lib'
    if /bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils  -I../include   -g -O2 -MT mhash.lo -MD -MP -MF ".deps/mhash.Tpo" -c -o mhash.lo mhash.c; \
            then mv -f ".deps/mhash.Tpo" ".deps/mhash.Plo"; else rm -f ".deps/mhash.Tpo"; exit 1; fi
    mkdir .libs
     gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils -I../include -g -O2 -MT mhash.lo -MD -MP -MF .deps/mhash.Tpo -c mhash.c  -fPIC -DPIC -o .libs/mhash.o
     gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils -I../include -g -O2 -MT mhash.lo -MD -MP -MF .deps/mhash.Tpo -c mhash.c -o mhash.o >/dev/null 2>&1
    if /bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils  -I../include   -g -O2 -MT stdfns.lo -MD -MP -MF ".deps/stdfns.Tpo" -c -o stdfns.lo stdfns.c; \
            then mv -f ".deps/stdfns.Tpo" ".deps/stdfns.Plo"; else rm -f ".deps/stdfns.Tpo"; exit 1; fi
     gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils -I../include -g -O2 -MT stdfns.lo -MD -MP -MF .deps/stdfns.Tpo -c stdfns.c  -fPIC -DPIC -o .libs/stdfns.o
     gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils -I../include -g -O2 -MT stdfns.lo -MD -MP -MF .deps/stdfns.Tpo -c stdfns.c -o stdfns.o >/dev/null 2>&1
    if /bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils  -I../include   -g -O2 -MT keygen_hex.lo -MD -MP -MF ".deps/keygen_hex.Tpo" -c -o keygen_hex.lo keygen_hex.c; \
            then mv -f ".deps/keygen_hex.Tpo" ".deps/keygen_hex.Plo"; else rm -f ".deps/keygen_hex.Tpo"; exit 1; fi
     gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils -I../include -g -O2 -MT keygen_hex.lo -MD -MP -MF .deps/keygen_hex.Tpo -c keygen_hex.c  -fPIC -DPIC -o .libs/keygen_hex.o
     gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils -I../include -g -O2 -MT keygen_hex.lo -MD -MP -MF .deps/keygen_hex.Tpo -c keygen_hex.c -o keygen_hex.o >/dev/null 2>&1
    if /bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils  -I../include   -g -O2 -MT keygen_mcrypt.lo -MD -MP -MF ".deps/keygen_mcrypt.Tpo" -c -o keygen_mcrypt.lo keygen_mcrypt.c; \
            then mv -f ".deps/keygen_mcrypt.Tpo" ".deps/keygen_mcrypt.Plo"; else rm -f ".deps/keygen_mcrypt.Tpo"; exit 1; fi
     gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils -I../include -g -O2 -MT keygen_mcrypt.lo -MD -MP -MF .deps/keygen_mcrypt.Tpo -c keygen_mcrypt.c  -fPIC -DPIC -o .libs/keygen_mcrypt.o
     gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils -I../include -g -O2 -MT keygen_mcrypt.lo -MD -MP -MF .deps/keygen_mcrypt.Tpo -c keygen_mcrypt.c -o keygen_mcrypt.o >/dev/null 2>&1
    if /bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils  -I../include   -g -O2 -MT keygen_asis.lo -MD -MP -MF ".deps/keygen_asis.Tpo" -c -o keygen_asis.lo keygen_asis.c; \
            then mv -f ".deps/keygen_asis.Tpo" ".deps/keygen_asis.Plo"; else rm -f ".deps/keygen_asis.Tpo"; exit 1; fi
     gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils -I../include -g -O2 -MT keygen_asis.lo -MD -MP -MF .deps/keygen_asis.Tpo -c keygen_asis.c  -fPIC -DPIC -o .libs/keygen_asis.o
     gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils -I../include -g -O2 -MT keygen_asis.lo -MD -MP -MF .deps/keygen_asis.Tpo -c keygen_asis.c -o keygen_asis.o >/dev/null 2>&1
    if /bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils  -I../include   -g -O2 -MT keygen.lo -MD -MP -MF ".deps/keygen.Tpo" -c -o keygen.lo keygen.c; \
            then mv -f ".deps/keygen.Tpo" ".deps/keygen.Plo"; else rm -f ".deps/keygen.Tpo"; exit 1; fi
     gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils -I../include -g -O2 -MT keygen.lo -MD -MP -MF .deps/keygen.Tpo -c keygen.c  -fPIC -DPIC -o .libs/keygen.o
     gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils -I../include -g -O2 -MT keygen.lo -MD -MP -MF .deps/keygen.Tpo -c keygen.c -o keygen.o >/dev/null 2>&1
    if /bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils  -I../include   -g -O2 -MT keygen_s2k.lo -MD -MP -MF ".deps/keygen_s2k.Tpo" -c -o keygen_s2k.lo keygen_s2k.c; \
            then mv -f ".deps/keygen_s2k.Tpo" ".deps/keygen_s2k.Plo"; else rm -f ".deps/keygen_s2k.Tpo"; exit 1; fi
     gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils -I../include -g -O2 -MT keygen_s2k.lo -MD -MP -MF .deps/keygen_s2k.Tpo -c keygen_s2k.c  -fPIC -DPIC -o .libs/keygen_s2k.o
     gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils -I../include -g -O2 -MT keygen_s2k.lo -MD -MP -MF .deps/keygen_s2k.Tpo -c keygen_s2k.c -o keygen_s2k.o >/dev/null 2>&1
    if /bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils  -I../include   -g -O2 -MT crc32.lo -MD -MP -MF ".deps/crc32.Tpo" -c -o crc32.lo crc32.c; \
            then mv -f ".deps/crc32.Tpo" ".deps/crc32.Plo"; else rm -f ".deps/crc32.Tpo"; exit 1; fi
     gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils -I../include -g -O2 -MT crc32.lo -MD -MP -MF .deps/crc32.Tpo -c crc32.c  -fPIC -DPIC -o .libs/crc32.o
     gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils -I../include -g -O2 -MT crc32.lo -MD -MP -MF .deps/crc32.Tpo -c crc32.c -o crc32.o >/dev/null 2>&1
    if /bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils  -I../include   -g -O2 -MT adler32.lo -MD -MP -MF ".deps/adler32.Tpo" -c -o adler32.lo adler32.c; \
            then mv -f ".deps/adler32.Tpo" ".deps/adler32.Plo"; else rm -f ".deps/adler32.Tpo"; exit 1; fi
     gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils -I../include -g -O2 -MT adler32.lo -MD -MP -MF .deps/adler32.Tpo -c adler32.c  -fPIC -DPIC -o .libs/adler32.o
     gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils -I../include -g -O2 -MT adler32.lo -MD -MP -MF .deps/adler32.Tpo -c adler32.c -o adler32.o >/dev/null 2>&1
    if /bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils  -I../include   -g -O2 -MT md2.lo -MD -MP -MF ".deps/md2.Tpo" -c -o md2.lo md2.c; \
            then mv -f ".deps/md2.Tpo" ".deps/md2.Plo"; else rm -f ".deps/md2.Tpo"; exit 1; fi
     gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils -I../include -g -O2 -MT md2.lo -MD -MP -MF .deps/md2.Tpo -c md2.c  -fPIC -DPIC -o .libs/md2.o
     gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils -I../include -g -O2 -MT md2.lo -MD -MP -MF .deps/md2.Tpo -c md2.c -o md2.o >/dev/null 2>&1
    if /bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils  -I../include   -g -O2 -MT md4.lo -MD -MP -MF ".deps/md4.Tpo" -c -o md4.lo md4.c; \
            then mv -f ".deps/md4.Tpo" ".deps/md4.Plo"; else rm -f ".deps/md4.Tpo"; exit 1; fi
     gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils -I../include -g -O2 -MT md4.lo -MD -MP -MF .deps/md4.Tpo -c md4.c  -fPIC -DPIC -o .libs/md4.o
     gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils -I../include -g -O2 -MT md4.lo -MD -MP -MF .deps/md4.Tpo -c md4.c -o md4.o >/dev/null 2>&1
    make[1]: *** [md4.lo] Error 1
    make[1]: Leaving directory `/usr/local/directadmin/custombuild/mhash-0.9.9/lib'
    make: *** [all-recursive] Error 1

    options.conf:
    Code:
    mysql=5.0
    default_php=5
    php4_cli=no
    php4_cgi=no
    php5_cli=yes
    php5_cgi=no
    apache_ver=2.2
    mail-header-patch=yes
    dovecot=no
    clean=yes
    DirectAdmin Values:
    Code:
    Compiled for	Debian 3.1 (no idea why it says 3.1 here on a fresh etch install)
    Server Version	1.30.2

  2. #2
    Hello,

    The line is generating the error
    Code:
     gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils -I../include -g -O2 -MT md4.lo -MD -MP -MF .deps/md4.Tpo -c md4.c -o md4.o >/dev/null 2>&1
    the problem is that the bit ">/dev/null 2>&1" means "dont show any errors, or any output"... so we really have no clue why it's having problems.

    If youre able, try changing directories into the mhash-0.9.9/libs directory, and running:
    Code:
    cd /usr/local/directadmin/custombuild/mhash-0.9.9/lib
     gcc -DHAVE_CONFIG_H -I. -I. -I../include/mutils -I../include -g -O2 -MT md4.lo -MD -MP -MF .deps/md4.Tpo -c md4.c -o md4.o
    without the piping to /dev/null, so we might be able to get some errors.

    Past that, you can just try an older version of mhash to see if that works. This can be accomplished by editing the build script to change the version:
    MHASH_VER=0.9.9
    to
    MHASH_VER=0.9.2
    (to give it a try), then type:
    Code:
    ./build update_data
    ./build mhash
    to see if that fixes it.

    And 3.1 is normal. Debian 4.0 still use the Debian 3.1 DA binaries, they work fine.

    John

  3. #3
    Join Date
    Jun 2007
    Posts
    10
    cheers John..

    uhm... eh... while beeing bored while waiting for a reply i did a
    Code:
    cd /usr/local/directadmin/
    rm -rf custombuild
    tar zxvf custombuild.tar.gz
    cd custombuild
    ./build update_data
    ./build all d
    ./build mysql
    and... it all worked..
    so i kinda missed the chance to debug this further *doh*.
    ill see if i can recreate it with a clean install on a dev server tomorrow.

    are there any way i can check if mhash is actually working as intended?

  4. #4
    create an info.php file, and put the following inside it:
    Code:
    <? phpinfo(); ?>
    then view it through apache. Scroll down to see if there is an mhash section.

    John

  5. #5
    Join Date
    Jun 2007
    Posts
    10
    cheers.
    seems everything is a-ok

Similar Threads

  1. Debian Etch.
    By MadHag in forum Debian
    Replies: 6
    Last Post: 09-03-2008, 06:02 PM
  2. Can't install on Debian Etch
    By dmytro in forum Installation / System Requirements
    Replies: 3
    Last Post: 02-23-2008, 02:11 AM
  3. debian etch & SA
    By ikaRus in forum Debian
    Replies: 1
    Last Post: 02-20-2008, 12:31 PM
  4. Debian Etch support
    By decibel83 in forum Installation / System Requirements
    Replies: 3
    Last Post: 09-19-2007, 08:07 PM
  5. Debian Etch
    By bmartin in forum General Technical Discussion & Troubleshooting
    Replies: 0
    Last Post: 08-14-2007, 01:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •