Results 1 to 13 of 13

Thread: pop and imap working together (delete)

  1. #1
    Join Date
    Jun 2009
    Posts
    37

    Question pop and imap working together (delete)

    Hello,

    I'm havind difficulties with my setup concerning imap. I tried looking on the forums, but nothing really seems to cover my issue.

    First of all, my imap and pop3 are working fine seperately for my account. But (here it comes), they are not working fine together.

    On my desktop pc I have installed the pop3 account, which when I receive my emails deletes the mails on the server too (works fine). But now for when I'm on the road, I use imap to access my email account from my mobile phone. It's just to make quick replies (if needed) and most of all I use it to delete any spam messages (so when I get home and open my email on my desktop I will only get the useful mails). But here it fails, whenever I delete a message via imap it's not being deleted on the server (same for setting a message as read). When I login to the webmail I see the message is still there, same when I get mail email on my desktop pc (pop-account).

    Is there any way I can solve this issue, so when I delete an email on imap, it also automatically gets deleted on pop3? I was using another setup before and there it worked correctly, but since I switched to DA, this keeps on failing. So I know it should work in one way or another.

    Thanks in advance...

  2. #2
    Join Date
    Oct 2007
    Location
    Switzerland
    Posts
    861
    IMAP and POP3 are just interfaces to the mbox/Maildir flat database, which contains all your messages at once. There is no such thing as IMAP and POP3 working separately.

    From what I can understand either your mobile phone is configured incorrectly or it marks deleted messages for deletion and it hides them but keeps them for some time.
    This happens for example with Snapper on my Palm, deleted messages remain for a couple of hours.
    This is a common behaviour of embedded IMAP clients to avoid a connection every time you delete a message, but for some reason even when I synchronize manually my messages with Snapper the deleted messages are still there, marked for deletion.

    Read the documentation of your IMAP client.
    Martino Dell'Ambrogio <tillo@tillo.ch> http://www.tillo.ch/ Security Auditor

  3. #3
    Join Date
    Jun 2009
    Posts
    37
    Ok, if it can help someone further, the mobile phone is an iPhone. Now I doubt that the problem is situated there, since as I mentioned with my previous server-setup everything just runs smooth, so it really gives the delete-state update to the server. Now I thought of that too before, so after I deleted it, I manually synced with the server again, to make sure the latest changes were sent to the server too.
    Sometimes it takes a couple of days before I reach my desktop pc again, so it can take up to a couple of hours maybe, but certainly no days as you described I guess, else there is no much use to imap or deleting a mail...

    So I know the iPhone functions correctly frfom my previous setup (account on iphone stayed, I've updated the link between local folders and remote folders off course)... only the server part was changed. It must be something server related, so I won't find it back in the manual of the IMAP client I guess?

  4. #4
    Join Date
    Oct 2007
    Location
    Switzerland
    Posts
    861
    You are right, if it worked before it should be working now.
    I can think of those other possible reasons:
    - if someone else uses your desktop computer and has access to your Email client's profile, maybe he/she downloads messages via POP3 before being deleted by your iPhone via IMAP
    - incompatibility between Apple's Mail on iPhone and DA's configuration of Dovecot (which is very unlikely)

    When I can think of anything else I'll post
    Martino Dell'Ambrogio <tillo@tillo.ch> http://www.tillo.ch/ Security Auditor

  5. #5
    Join Date
    Jun 2009
    Posts
    37
    Thank you so far, for thinking this over with me!

    I'm the only one access my desktop pc, it's password protected and it's located in private area.
    As a matter of fact I've been testing things today, while I was behind my desktop computer with my phone next to me, so I could try to figure out what goes wrong, so it can save me some time afterwards.
    The strange thing is that when I delete a mail on my phone, it even doesn't get deleted from the webmail (which is directly on the server), so that's why it's also on the pop3 probably.

    Now with the imap settings, I see the folder INBOX to related with my local inbox folder on the phone. but I also see a (grayed-out) folder with my domainname, but I can't select it. This is something new, since on my previous setup I didn't have this unselectable folder (but I guess this is something specific for DA)?

  6. #6
    Join Date
    Oct 2007
    Location
    Switzerland
    Posts
    861
    Webmails use IMAP, so if you see the deleted mail while you don't see it in Apple's Mail it could be a matter of compatibility.
    I know that Dovecot has a weird setting: every special directory (Trash, Sent, Drafts) resides in the INBOX directory, that's why in all webmails you have to prefix them with "INBOX." ("." being the character between folders in IMAP, just like "/" in a file system). Try to find that setting in Mail, maybe it's related. For example if you have a setting for the Trash directory, change "Trash" in "INBOX.Trash".
    Martino Dell'Ambrogio <tillo@tillo.ch> http://www.tillo.ch/ Security Auditor

  7. #7
    Join Date
    Jun 2009
    Posts
    37
    Yes, you are correct.
    But th iPhone is prettey smart on this kind of stuff, in the menu where you can map the different folders it gives you a list of the available folders on the server. So for trash I have selected the remote folder (on server) INBOX.Trash. I've always configured it like this, but appearantly it's not enough... There is also another setting called "prefix IMAP-pad", this is default "/". I tried changing this to INBOX, but then no remote folders are available (Trash, Sent, ...). Only the inbox is working then... (deleting mail, keeps it still on the server, webmail)
    So until now, no further luck with your suggestions.

  8. #8
    Join Date
    Jun 2003
    Location
    California
    Posts
    26,122
    Quote Originally Posted by tillo View Post
    Webmails use IMAP
    Unless it's been changed in a recent update (I don't think so), UebiMiau is set to use POP and not IMAP, so that depends on which Webmail client you're using.

    Jeff
    +1 951 643-5345
    Third-Party DirectAdmin administration and support
    Dedicated Servers, Dedicated Reseller Accounts
    NoBaloney Internet Services div. Qnito Incorporated
    848 North Rainbow Blvd., Suite #3789
    Las Vegas, NV 89107-1103

  9. #9
    Join Date
    Jun 2009
    Posts
    37
    Quote Originally Posted by jlasman View Post
    Unless it's been changed in a recent update (I don't think so), UebiMiau is set to use POP and not IMAP, so that depends on which Webmail client you're using.

    Jeff
    Hmm, Ok this would again explain why the deleted mail is still visible (because I'm using UebiMiau) ... since it is on my pop3 account also still visible.

    I'll try to see if I can switch to another webmail system, so I can see if my delete-command reaches the server or not.

  10. #10
    Join Date
    Jun 2009
    Posts
    37
    Ok, I'm pretty sure it has something to do with DA now. I used squirrelmail for checking the server side (this is IMAP based) and it appears that my deleted emails are indeed be moved to Trash etc... so the interaction between my phone and the server are OK.

    You can now see this also as: email being deleted on webmail (squirrelmail) isn't being deleted on the pop3

  11. #11
    Join Date
    Oct 2007
    Location
    Switzerland
    Posts
    861
    I may have an idea: POP3 doesn't support folders, so when you fetch the messages any message will be downloaded. Instead of making your IMAP client to move the message from INBOX to INBOX.Trash make it remove it completely.
    Or, as an alternative, use IMAP on your desktop computer too that's what most people do.
    Martino Dell'Ambrogio <tillo@tillo.ch> http://www.tillo.ch/ Security Auditor

  12. #12
    Join Date
    Jun 2009
    Posts
    37
    Great man! It's working! I have to remove to a local folder on my phone (instead of INBOX.Trash). It's then being completely removed as you suggested (on IMAP and also POP).

    PS: The reason I use pop3 on my desktop computer, is to have the mail deleted from the server, since it's a very busy account, I would like to use my local harddrive space instead of using all my server space to this...

    Thank you very much for your support.

  13. #13
    Join Date
    Jun 2009
    Posts
    37
    So it worked until I updated directadmin again...

    Any new suggestions somebody?

    Thanks in advance

Similar Threads

  1. Can not get php imap working
    By Dougy in forum General Technical Discussion & Troubleshooting
    Replies: 5
    Last Post: 09-03-2010, 10:46 AM
  2. External IMAP not working
    By DragonWize in forum E-Mail
    Replies: 1
    Last Post: 11-04-2006, 10:11 AM
  3. IMAP not working?
    By roel in forum E-Mail
    Replies: 3
    Last Post: 04-15-2005, 01:18 AM
  4. imap not working, everything set right...
    By mcanale in forum E-Mail
    Replies: 3
    Last Post: 03-23-2004, 09:55 AM
  5. Delete an IMAP account?
    By NightStorm in forum User-Level Difficulties
    Replies: 2
    Last Post: 12-02-2003, 02:51 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •