Results 1 to 4 of 4

Thread: Dovecot wont start after clean install DA

  1. #1
    Join Date
    Dec 2010
    Posts
    3

    Exclamation Dovecot wont start after clean install DA

    Process Dovecot not start after clean intall DA on clean FreeBSD 7.3

    Dec 18 11:20:00 mike dovecot[1300]: auth(default): Fatal: Support not compiled in for passdb driver 'shadow'
    Dec 18 11:20:00 mike dovecot[1300]: dovecot: Fatal: Auth process died too early - shutting down
    Dec 18 11:20:12 mike dovecot[1312]: auth(default): Fatal: Support not compiled in for passdb driver 'shadow'
    Dec 18 11:20:12 mike dovecot[1312]: dovecot: Fatal: Auth process died too early - shutting down
    # dovecot --build-options
    Build options: ioloop=kqueue notify=kqueue ipv6 openssl
    Mail storages: cydir dbox maildir mbox raw shared
    SQL drivers:
    Passdb: checkpassword pam passwd passwd-file
    Userdb: nss passwd passwd-file prefetch static
    Any idea how to fix that ?

  2. #2
    Join Date
    Dec 2010
    Posts
    3
    Dovecot process start when i run this line:

    perl -pi -e 's/passdb shadow/passdb passwd/' /etc/dovecot.conf
    we will si now if everything will be ok.

  3. #3
    Hello,

    Thanks, I've added that to the build script, run if the OS is FreeBSD.

    John

  4. #4
    Join Date
    Nov 2010
    Posts
    23
    Run the following commands:

    Code:
    /usr/local/etc/rc.d/da-popb4smtp stop
    Code:
    /usr/local/etc/rc.d/vm-pop3d.sh stop
    Code:
    service dovecot stop
    Code:
    service dovecot start
    Code:
    service dovecot status
    and give us the result.

    Don't forget to start back the pop3/smtp

    Code:
    /usr/local/etc/rc.d/da-popb4smtp start
    Code:
    /usr/local/etc/rc.d/vm-pop3d.sh start
    -j0

Similar Threads

  1. Named doesn't start after clean install
    By Suurbier in forum General Technical Discussion & Troubleshooting
    Replies: 0
    Last Post: 09-17-2012, 04:25 AM
  2. httpd wont start
    By gaz0r in forum Apache (WWW)
    Replies: 9
    Last Post: 03-07-2009, 09:23 PM
  3. httpd doesn't start after clean directadmin setup!!!
    By Stepashka in forum CustomBuild
    Replies: 5
    Last Post: 02-15-2009, 11:58 AM
  4. How clean is a clean install?
    By emmanuel in forum Installation / System Requirements
    Replies: 5
    Last Post: 05-13-2007, 07:10 AM
  5. dns wont start BIND 9.2.2-P3
    By Stormbox in forum DNS
    Replies: 4
    Last Post: 08-03-2004, 03:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •