Page 2 of 2 FirstFirst 12
Results 21 to 36 of 36

Thread: Proftpd update

  1. #21
    Join Date
    Jun 2009
    Location
    Szczecin / Poland
    Posts
    22
    Hello,

    I confirm, I have the same problem (FreeBSD 7.3 and 8.1).

    Regards

  2. #22
    Join Date
    Aug 2008
    Posts
    4,695
    Quote Originally Posted by dudek888 View Post
    Hello,

    I confirm, I have the same problem (FreeBSD 7.3 and 8.1).

    Regards
    cd /usr/ports/devel/gettext && make install clean

  3. #23
    Join Date
    Jun 2009
    Location
    Szczecin / Poland
    Posts
    22
    # pkg_info | grep gettext

    gettext-0.17_1 GNU gettext package
    p5-gettext-1.05_3 Message handling functions


    Regards

  4. #24
    Join Date
    Jul 2007
    Posts
    178
    It doesn't install from the ./build script but manually it works.

    If you get the gmake errror, press ctrl+z to put the script in the background, cd into the proftpd-1.3.3e directory, run ./configure, cd up 1 directory, 'fg' + enter to get the script back to the foreground, type 'y' + enter (You won't see a prompt as the script is still waiting on the y/n input to retry the build.

  5. #25
    Join Date
    Jul 2008
    Posts
    3
    Quote Originally Posted by sysdev View Post
    It doesn't install from the ./build script but manually it works.

    If you get the gmake errror, press ctrl+z to put the script in the background, cd into the proftpd-1.3.3e directory, run ./configure, cd up 1 directory, 'fg' + enter to get the script back to the foreground, type 'y' + enter (You won't see a prompt as the script is still waiting on the y/n input to retry the build.
    run ./configure
    run: Command not found.

  6. #26
    Join Date
    Jul 2008
    Posts
    3
    cd into the proftpd-1.3.3e
    and
    make && make install
    and
    ProFTPd 1.3.3e Running

  7. #27
    Join Date
    Jul 2007
    Posts
    178
    Quote Originally Posted by akkabarakka View Post
    run ./configure
    run: Command not found.
    Yeah, well... you should run './configure'
    At least on FreeBSD, on CentOS you can skip the './configure'. Actually you can skip everthing after the './build proftpd' on CentOS as it seems to work on that OS without problems.

    # ./buildd proftpd
    /* wait for error and prompt 'y/n retry stuff'
    press [CTRL] + z
    # cd proftpd-1.3.3e
    # ./configure
    # cd ..
    # fg
    press 'y' + [ENTER]

  8. #28
    Join Date
    Jun 2009
    Location
    Szczecin / Poland
    Posts
    22
    If you get the gmake errror, press ctrl+z to put the script in the background, cd into the proftpd-1.3.3e directory, run ./configure, cd up 1 directory, 'fg' + enter to get the script back to the foreground, type 'y' + enter (You won't see a prompt as the script is still waiting on the y/n input to retry the build.

    Thanks sysdev. This trick work perfectly.


    Regards

  9. #29
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    8,127
    If you would like to disable nls (it was added about a month ago):
    Code:
    cd /usr/local/directadmin/custombuild
    mkdir custom/proftpd
    cp -pf configure/proftpd/configure.proftpd custom/proftpd/configure.proftpd
    perl -pi -e 's|--enable-nls \\\n||' custom/proftpd/configure.proftpd
    Also, for those who did not know, pure-ftpd support is now available:
    Code:
    cd /usr/local/directadmin/custombuild
    ./build update
    ./build set proftpd no
    ./build set pureftpd yes
    ./build pureftpd
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  10. #30
    Hello,

    I tested on both 32-bit and 64-bit systems, and got the same error, but only on FreeBSD.
    I tried some quick port reinstalls of gettext, but the proftpd configure still couldn't find it. I'm not sure if it's a proftpd bug, library issue (not likely) or a configure option we're missing (I didn't notice any for nls).

    So for the time being I've updated custombuild to do a perl regex to swap enable-nls with disable-nls if the OS is freebsd. This only applies to the main configure/proftpd/configure.proftpd file. If you're running a custom/proftpd/configure.proftpd file, the swap won't happen (in case you made it work.. in which case, do share)

    So for anyone affected, just type:
    Code:
    ./build update
    ./build proftpd
    should sort it out, then the custom configure.proftpd won't be required, so you can remove it.

    John

  11. #31
    Join Date
    Apr 2009
    Posts
    2,420
    Quote Originally Posted by DirectAdmin Support View Post
    ...So for the time being I've updated custombuild to do a perl regex to swap enable-nls with disable-nls if the OS is freebsd. This only applies to the main configure/proftpd/configure.proftpd file. If you're running a custom/proftpd/configure.proftpd file, the swap won't happen (in case you made it work.. in which case, do share)
    It is important that we keep enable-nls, if not everyone that is uploading files with file names with special characters (like and and ), will get problems that those files do not work in a web browser.

    Lucky me I am not on FreeBSD, but using CentOS, so I am not affected. But it is not a good solution to disable enable-nls - and if so happen, you must let us know about it in advance.

  12. #32
    Hello,

    It wasn't my first choice. After about an hour of debugging with it, I gave up and turned it off. The issue isn't closed though, if we find a fix, it will be enabled again.

    John

  13. #33
    Join Date
    Mar 2007
    Posts
    94
    Hi,

    is anything new about that? Im on freebsd 9.1 and still the same. It was also the same on 8.2. Any tip?

  14. #34
    Join Date
    Aug 2004
    Location
    uk
    Posts
    1,584
    This is clearly a bug in the proftpd configure script, after I find a fix I will file the fix on github for them to fix.

  15. #35
    Join Date
    May 2014
    Location
    Netherlands Germany
    Posts
    558
    Quote Originally Posted by Chrysalis View Post
    This is clearly a bug in the proftpd configure script, after I find a fix I will file the fix on github for them to fix.
    OLD TOPIC sorry

    But any news on this?
    DUTCH GERMAN, GERMAN DUTCH

  16. #36
    Join Date
    May 2008
    Location
    Bulgaria
    Posts
    969
    I was able to compile ProFTP with --enable-nls by doing this addition to the configure script:

    Code:
    #!/bin/sh
    install_user=ftp \
    install_group=ftp \
    ./configure \
    --prefix=/usr/local \
    --sysconfdir=/etc \
    --localstatedir=/var/run \
    --mandir=/usr/share/man \
    --without-pam \
    --disable-auth-pam \
    --enable-nls \
    --enable-dso \
    --with-modules=mod_ratio:mod_readme:mod_tls \
    --with-libraries=/usr/local/lib
    The addition is the final line. I fetched it from the proftpd FreeBSD port.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Exclude yum update proftpd
    By Anton in forum General Technical Discussion & Troubleshooting
    Replies: 2
    Last Post: 09-09-2012, 03:47 AM
  2. How-To Update ProFTPD
    By @how@ in forum How-To Guides
    Replies: 63
    Last Post: 11-20-2009, 10:34 PM
  3. how to update proftpd?
    By lkbryant in forum General Technical Discussion & Troubleshooting
    Replies: 9
    Last Post: 12-15-2008, 11:35 AM
  4. ProFTPd update?
    By ActiveDomain.NL in forum DirectAdmin General Discussion
    Replies: 24
    Last Post: 01-12-2006, 10:00 PM
  5. ProFTPD 1.2.9 Security Update?
    By woeger in forum DirectAdmin General Discussion
    Replies: 4
    Last Post: 11-09-2003, 02:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •