Results 1 to 5 of 5

Thread: Error, SSL/TLS libraries were missing or unusable

  1. #1
    Join Date
    Mar 2010
    Posts
    42

    Error, SSL/TLS libraries were missing or unusable

    Hi,

    I have a clean version of CentOS and while installing DirectAdmin I get the following error message:

    Code:
    configure: error: ... Error, SSL/TLS libraries were missing or unusable
    
    *** There was an error while trying to configure Apache 2. Check the configure/ap2/configure.apache file

    I have the following installed:
    openssl.i686 0.9.8e-12.el5_4.1 installed
    openssl-devel.i386 0.9.8e-12.el5_4.1 installed

  2. #2
    Join Date
    May 2003
    Posts
    251
    here the same errror.. in centos 5 32bits, Virtual server..
    OutPerNet webservices
    www.outper.net
    Cloud shared-dedicated / Colo in Argentina

  3. #3
    Join Date
    May 2012
    Posts
    4

    Issue with apache "configure: error: ... Error, SSL/TLS libraries were missing...."

    Hi,

    I am getting the same error i.e configure: error: ... Error, SSL/TLS libraries were missing or unusable wile installing apache2.2.22.

    Initially I have older version of openssl and evything was fine but then I need to install updated version of openssl i.e openssl-1.0d and do that successfully but after that when I configure apache I am getting this error, please see below

    checking for openssl/engine.h... yes
    checking for SSLeay_version... yes
    checking for SSL_CTX_new... no
    checking for ENGINE_init... no
    checking for ENGINE_load_builtin_engines... no
    checking for SSL_set_cert_store... no
    configure: error: ... Error, SSL/TLS libraries were missing or unusable


    openssl-devel is already installed on my box..
    Please let me know if anyone has good suggestion.

    Thanks in advance.

    Regards,
    Riya Aggarwal

  4. #4
    Join Date
    Jun 2003
    Location
    California
    Posts
    26,122
    Are you installing apache as new, or just updating it? What command are you using? Do you have a DirectAdmin-based server?

    Jeff
    +1 951 643-5345
    Third-Party DirectAdmin administration and support
    Dedicated Servers, Dedicated Reseller Accounts
    NoBaloney Internet Services div. Qnito Incorporated
    848 North Rainbow Blvd., Suite #3789
    Las Vegas, NV 89107-1103

  5. #5
    Join Date
    May 2012
    Posts
    4

    solution for "configure: error: ... Error, SSL/TLS libraries were missing or unusabl"

    I was installing apache as new , and now i found the solution.

    use : env LDFLAGS="-ldl" before configure command.

    This makes my configure command run without any error that I was facing previously.

    Thanks and Regards,
    Riya Aggarwal

Similar Threads

  1. Webalizer : Error while loading shared libraries: libdb-4.7.so
    By webunder in forum General Technical Discussion & Troubleshooting
    Replies: 9
    Last Post: 04-18-2012, 08:30 AM
  2. Replies: 4
    Last Post: 02-02-2011, 11:10 AM
  3. Missing libraries on first time DA Installation
    By beansbaxter in forum Installation / System Requirements
    Replies: 4
    Last Post: 10-03-2010, 06:35 AM
  4. configure: error: Kerberos libraries not found.
    By mitya3003 in forum General Technical Discussion & Troubleshooting
    Replies: 8
    Last Post: 06-18-2010, 08:56 AM
  5. curl: error while loading shared libraries: libcurl.so.3
    By Drowned in forum General Technical Discussion & Troubleshooting
    Replies: 1
    Last Post: 02-10-2005, 07:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •