Page 2 of 2 FirstFirst 12
Results 21 to 30 of 30

Thread: Apache 2.4.1 update - URGENT-

  1. #21
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    7,442
    Code:
    buildconf: You need autoconf 2.59 or lower to build this version of PHP.            You are currently trying to use 2.63            Most distros have separate autoconf 2.13 or 2.59 packages.
    Is the problem. It doesn't work properly with autoconf >2.59. I may add more checks to CB for it or re-add a PHP tarballs with a fixed "configure" file.
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  2. #22
    Join Date
    Jun 2007
    Location
    California
    Posts
    498
    I've responded to your email. Can I somehow get the old version of autoconf through custombuild?

    Thanks.

    Jeff
    Serving the DirectAdmin community since 2003
    See Additional posts under user nobaloney

    directadmin@nobaloney.net +1 951 643-5345
    Contract DirectAdmin administration and support
    Dedicated Servers, Dedicated Reseller Accounts
    http://www.nobaloney.net
    NoBaloney Internet Services div. Qnito Incorporated
    848 North Rainbow Blvd., Suite #3789
    Las Vegas, NV 89107-1103

  3. #23
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    7,442
    Quote Originally Posted by NoBaloney2 View Post
    I've responded to your email. Can I somehow get the old version of autoconf through custombuild?

    Thanks.

    Jeff
    There is no autoconf <2.61 available on DA servers, however, your server runs CentOS 6.2 (default autoconf is 2.63), but it has an autoconf-213 package, which can be installed using yum (yum install autoconf-213).
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  4. #24
    Join Date
    Jun 2003
    Location
    California
    Posts
    26,122
    Quote Originally Posted by smtalk View Post
    There is no autoconf <2.61 available on DA servers, however, your server runs CentOS 6.2 (default autoconf is 2.63), but it has an autoconf-213 package, which can be installed using yum (yum install autoconf-213).
    Thanks!

    Jeff
    +1 951 643-5345
    Third-Party DirectAdmin administration and support
    Dedicated Servers, Dedicated Reseller Accounts
    NoBaloney Internet Services div. Qnito Incorporated
    848 North Rainbow Blvd., Suite #3789
    Las Vegas, NV 89107-1103

  5. #25
    Join Date
    Jul 2009
    Posts
    23
    Quote Originally Posted by smtalk View Post
    Code:
    buildconf: You need autoconf 2.59 or lower to build this version of PHP.            You are currently trying to use 2.63            Most distros have separate autoconf 2.13 or 2.59 packages.
    Is the problem. It doesn't work properly with autoconf >2.59. I may add more checks to CB for it or re-add a PHP tarballs with a fixed "configure" file.
    Just repackage PHP with the fixed file. It's faster, and has far less dependencies.

  6. #26
    Join Date
    Jan 2007
    Posts
    32
    yum install autoconf213
    export PHP_AUTOCONF=/usr/bin/autoconf-2.13

    this fixed to the problem for me on centos 6.2

  7. #27
    Join Date
    Oct 2010
    Location
    Iceland
    Posts
    104
    Code:
    Stopping httpd:                                            [  OK  ]
    Starting httpd: [Thu Sep 19 18:04:10.793587 2013] [core:warn] [pid 27795] AH00117: Ignoring deprecated use of DefaultType in line 61 of /etc/httpd/conf/httpd.conf.
    This is the error i am getting ? after upgrade or i did first the upgrade and then read on the forum if this happend then you should delete custombuild and reinstall it so i did that but i am still getting the error ? any ideas.

  8. #28
    Join Date
    Apr 2009
    Posts
    2,232
    Quote Originally Posted by Anton View Post
    Code:
    Stopping httpd:                                            [  OK  ]
    Starting httpd: [Thu Sep 19 18:04:10.793587 2013] [core:warn] [pid 27795] AH00117: Ignoring deprecated use of DefaultType in line 61 of /etc/httpd/conf/httpd.conf.
    This is the error i am getting ? after upgrade or i did first the upgrade and then read on the forum if this happend then you should delete custombuild and reinstall it so i did that but i am still getting the error ? any ideas.
    I have not read this old thread, but it does not sound like a good idea to delete "custombuild". Try this instead:

    Code:
    cd /usr/local/directadmin/custombuild
    ./build update
    ./build rewrite_confs

  9. #29
    Join Date
    Oct 2010
    Location
    Iceland
    Posts
    104
    Thank you sir that did the trick. Owe you a cold one

  10. #30
    Join Date
    Jan 2010
    Posts
    3

    Worked great

    Quote Originally Posted by smtalk View Post
    It is ready, but your configs are not. "custom" directory functionality is created for sysadmins (experts) only, you shouldn't use it. If you have an old configure.apache file, which is incompatible with apache 2.4, it won't work. CustomBuild doesn't touch "custom" directory at all. Do:
    Code:
    cd /usr/local/directadmin/custombuild
    mv custom custom_not_used
    ./build apache
    ./build php n
    And it will work with no problems.
    How can I make my server worker?
    Hello thank you for the help.I was trying to make mine from prefork to worker and this saved my butt.
    I do have a question as It would not load the memcache modules because it could not use them from the extention directory.

    I think it may be because of the headers in the php when I installed the custom apache.I did not run clean install on php but did on apache.

    I just edited apache custom biuld in the ap2 and added "--with-mpm=worker" \

    but it would not load the memcache or apc .

    Any ideas as to what I could do to change my apache to worker?

    Thank you

Page 2 of 2 FirstFirst 12

Similar Threads

  1. URGENT. After update restore fails
    By simba in forum General Technical Discussion & Troubleshooting
    Replies: 1
    Last Post: 12-03-2012, 07:04 AM
  2. apache is not restarting | Urgent
    By u4xlol in forum Apache (WWW)
    Replies: 1
    Last Post: 06-13-2010, 11:56 PM
  3. Replies: 3
    Last Post: 05-24-2008, 07:09 PM
  4. [URGENT] Anyone tried Apache, PHP etc from ports?
    By thoroughfare in forum FreeBSD 5.x
    Replies: 0
    Last Post: 02-13-2006, 10:25 AM
  5. URGENT: Killed Apache, PHP and SSL
    By cth3 in forum Apache (WWW)
    Replies: 2
    Last Post: 08-23-2004, 09:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •