Page 2 of 2 FirstFirst 12
Results 21 to 36 of 36

Thread: ImageMagick Install

  1. #21
    Join Date
    Apr 2012
    Location
    Rotterdam, Netherlands
    Posts
    219
    Thank you, that helped. I removed the function names that gave an error because they were in disable_functions. The error messages disapeard!

  2. #22
    Join Date
    Mar 2009
    Location
    The Netherlands
    Posts
    30
    If you run the test command "identify -version" and you get the following error:

    error while loading shared libraries: libMagickCore-6.Q16.so.1: cannot open shared object file: No such file or directory
    Use the following command to fix it:

    ldconfig /usr/local/lib

  3. #23
    Join Date
    May 2013
    Posts
    23
    in php5.4 i install imagemagic but i get this massage:
    PHP Warning: PHP Startup: imagick: Unable to initialize module
    Module compiled with module API=20090626
    PHP compiled with module API=20100525
    These options need to match
    in Unknown on line 0
    .........................................
    php5.4 and imagemagic not compatible!!?
    Can this problem be solved?

  4. #24
    Join Date
    Mar 2009
    Location
    The Netherlands
    Posts
    30
    Quote Originally Posted by beniii View Post
    in php5.4 i install imagemagic but i get this massage:
    PHP Warning: PHP Startup: imagick: Unable to initialize module
    Module compiled with module API=20090626
    PHP compiled with module API=20100525
    These options need to match
    in Unknown on line 0
    .........................................
    php5.4 and imagemagic not compatible!!?
    Can this problem be solved?
    You need to use the right phpize and the right ./configure string, try the following:

    I have PHP5.5 and PHP5.4 running on our webservers, so in my case it will be:

    [root@web ~]# find / -name phpize
    /usr/local/php54/bin/phpize
    /usr/local/php55/bin/phpize
    And then:

    [root@web ~]# find / -name php-config
    /usr/local/php54/bin/php-config
    /usr/local/php55/bin/php-config

    So if I want to install imagick for PHP5.4 it would be the following:

    /usr/local/php54/bin/phpize
    ./configure --with-php-config=/usr/local/php54/bin/php-config
    make
    make install

  5. #25
    Join Date
    Sep 2009
    Posts
    220
    Quote Originally Posted by uberook View Post
    Try the following if you're on Centos or alike:

    yum install php-devel ImageMagick ImageMagick-devel
    pecl install Imagick


    don't forget to add this to php.ini
    extension=imagick.so

    and then

    service httpd restart
    Thanks, This worked for me.

  6. #26
    Join Date
    Feb 2006
    Posts
    298
    Does anybody have tried this guide to centos 7?

  7. #27
    Join Date
    Mar 2016
    Posts
    10
    Quote Originally Posted by uberook View Post
    Try the following if you're on Centos or alike:

    yum install php-devel ImageMagick ImageMagick-devel
    pecl install Imagick


    don't forget to add this to php.ini
    extension=imagick.so

    and then

    service httpd restart

    OH MY GOSH. This finally did it for me. I just wasn't doing the php.ini part right I think. I wonder how I get all that other crap off my installation, lmao

  8. #28
    Join Date
    Aug 2014
    Posts
    78
    Perfect, I could install ghostscript with your guide :X

    thank you.

  9. #29
    Join Date
    Oct 2017
    Posts
    2

    imagic php module for php 5.3 debian wheezy/7

    Hello,

    i want to recompile this module after upgrade OS from debian squeeze/6 to wheezy/7.

    Installed packages:
    imagemagick 8:6.7.7.10-5+deb7u18
    imagemagick-common 8:6.7.7.10-5+deb7u18
    libmagic-dev:amd64 5.11-2+deb7u9
    libmagic1:amd64 5.11-2+deb7u9
    libmagick++3 8:6.6.0.4-3+squeeze6
    libmagick++5:amd64 8:6.7.7.10-5+deb7u18
    libmagickcore-dev 8:6.7.7.10-5+deb7u18
    libmagickcore3 8:6.6.0.4-3+squeeze6
    libmagickcore3-extra 8:6.6.0.4-3+squeeze6
    libmagickcore5:amd64 8:6.7.7.10-5+deb7u18
    libmagickcore5-extra:amd64 8:6.7.7.10-5+deb7u18
    libmagickwand-dev 8:6.7.7.10-5+deb7u18
    libmagickwand3 8:6.6.0.4-3+squeeze6
    libmagickwand5:amd64 8:6.7.7.10-5+deb7u18

    I compile it in this way:
    Code:
    wget http://pecl.php.net/get/imagick-3.0.1.tgz
    tar zxf imagick-3.0.1.tgz
    cd imagick-3.0.1
    /usr/local/bin/phpize
    ./configure --with-php-config=/usr/local/bin/php-config
    make
    make install
    It compiles, but test page doesn't work. No error in apache log or in page itself. For test page i use https://github.com/sirleech/php-imag...ster/hello.php

    I compared Makefile which was created on old system and upgraded and found such differences:
    Code:
    diff Makefile_deb7 /usr/src/imagick-3.0.1/Makefile_deb6
    14c14
    < IMAGICK_SHARED_LIBADD = -lMagickWand -lMagickCore
    ---
    > IMAGICK_SHARED_LIBADD = -lMagickWand -lMagickCore -llcms -ltiff -lfreetype -ljpeg -llqr-1 -lglib-2.0 -lfontconfig -lXext -lSM -lICE -lX11 -lXt -lbz2 -lz -lm -lgomp -lltdl
    44c44
    < SHELL = /bin/bash
    ---
    > SHELL = /bin/sh
    146d145
    <               TEST_RESULT_EXIT_CODE=$$?; \
    148d146
    <               exit $$TEST_RESULT_EXIT_CODE; \
    As i understand that difference comes from /usr/bin/MagickWand-config:
    Code:
    # /usr/bin/MagickWand-config-deb6  --libs
    -L/usr/lib -lMagickWand -lMagickCore -llcms -ltiff -lfreetype -ljpeg -llqr-1 -lglib-2.0 -lfontconfig -lXext -lSM -lICE -lX11 -lXt -lbz2 -lz -lm -lgomp -lpthread -lltdl
    # /usr/bin/MagickWand-config-deb7  --libs
    -lMagickWand -lMagickCore
    Does anyone have an idea how to compile it properly

  10. #30
    Join Date
    Jul 2014
    Posts
    155
    I found this post from Google when searching a tutorial to install Imagick
    Not sure I still can use these guides to install Imagick on my Centos 6 server?

    Or is there a simpler way to install Imagick on my Directadmin without running too many steps like this?

    Thanks
    The best internet marketing forum and smartphone forum for learning everything about marketing and smartphones.

  11. #31
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    13,750
    Posts #8, #25, #27 show a quick way to complete the installation.
    Regards, Alex G.

    - Get the best commercial DirectAdmin support and hire me on poralix.com
    - Follow and like @Poralix on Facebook

  12. #32
    Join Date
    Sep 2007
    Posts
    20
    /tmp directory is often non executable. The solution is to execute
    Code:
    pear config-set temp_dir /root/tmp
    before
    Code:
    pecl install Imagick
    . Sometimes you also have to install
    Code:
    yum install shtool

  13. #33
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    8,131
    imagick=yes/no is now a CB 2.0 options from rev. 2109 (defaults to "no"). Thank you!
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  14. #34
    Join Date
    Jun 2012
    Posts
    635
    Quote Originally Posted by smtalk View Post
    imagick=yes/no is now a CB 2.0 options from rev. 2109 (defaults to "no"). Thank you!
    Is this in the plugin?
    not seeing it on my end
    Dave M

  15. #35
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    8,131
    Fixed in CB 2.0 rev. 2132 (might take ~8 hours for the mirrors to have it), thank you for the report!
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  16. #36
    Join Date
    Jun 2012
    Posts
    635
    thank you checking now will report any issues
    Dave M

Page 2 of 2 FirstFirst 12

Similar Threads

  1. ImageMagick-6.7.9-2 install
    By Anton in forum 3rd Party Software
    Replies: 6
    Last Post: 08-31-2012, 12:37 PM
  2. ImageMagick Install Problem
    By BrianUK in forum FreeBSD 5.x
    Replies: 1
    Last Post: 05-25-2007, 07:42 AM
  3. How to install ImageMagick and SOX
    By manny2008 in forum DirectAdmin General Discussion
    Replies: 1
    Last Post: 04-25-2005, 09:43 AM
  4. Replies: 1
    Last Post: 12-25-2004, 09:40 AM
  5. websites not reachable after trying to install ImageMagick
    By testracer in forum General Technical Discussion & Troubleshooting
    Replies: 2
    Last Post: 12-20-2004, 12:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •