Results 1 to 5 of 5

Thread: Spamassassin install failed: GET 3.3 request faild

  1. #1
    Join Date
    Oct 2004
    Location
    Netherlands
    Posts
    20

    Spamassassin install failed: GET 3.3 request faild

    Hello,

    I try to install spamassassin, and I followed the tutorial from:
    http://help.directadmin.com/item.php?id=36

    I installed the cpan modules, that seems to go fine. But when I go to /usr/local/directadmin/scripts/ to run spam.sh I get the following error:

    [...]-DCONTACT_ADDRESS="the administrator of that system" -m644 -Irules -O/usr/share/spamassassin user_prefs.template languages sa-update-pubkey.txt
    chmod 755 /usr/share/spamassassin
    http: GET 3.3 request failed: 400 URL must be absolute: 400 URL must be absolute
    error: no mirror data available for channel updates.spamassassin.org
    channel: MIRRORED.BY contents were missing, channel failed


    run:
    /usr/bin/spamd -d -c -m 15
    Starting spamd doesnt work offcourse, also sa-update gives the same error as above.

    Anybody an idea what the error could be? Is the spamassassin updates mirror down?

    System details:
    Centos 6 x64 minimal
    Fresh install of directadmin

    Tested also on another system; had exactly the same error.

  2. #2
    Join Date
    Apr 2009
    Posts
    2,232
    It is now possible to install SpamAssassin using custombuild, so I think the article you link to need to be updated. To install SpamAssassin using custombuild, do this:

    Code:
    cd /usr/local/directadmin/custombuild
    ./build set spamassassin yes
    ./build update
    ./build versions
    ./build spamassassin

  3. #3
    Hello,

    We've seen a string of emails about this within the last week.
    Since we've not changed anything recently, my guess is that it's a change on the download server end..

    However, I did find this:
    http://www.directadmin.com/forum/sho...t=37777&page=1

    Which may indicate that it's related to IPv6, if your network doesn't support it.
    It's possible that a remote dns change to the download server (spamassasin.org) was changed in a manner that is breaking the install for box that have IPv6, but don't support it.

    Post #14 mentions how to shut off IPv6 if you don't need it (I've not tested it, nor confirmed that it's a working solution, but his reply might indicate that it does fix it)

    So if anyone does try it and it does fix the issue, please let us know!

    John

  4. #4
    Join Date
    Dec 2012
    Posts
    73
    I had the same issue on my new server i set up last weekend.
    sa-update fails to get the latest spamassassin rules set so the installation fails.
    This is how i solved it:
    download the ruleset to your server through wget (get the rules from spamassassin.org), make sure you also download GPG, MD5 and SHA1 signature files
    Mail-SpamAssassin-rules-3.3.2-r1104058.tar.gz
    Mail-SpamAssassin-rules-3.3.2-r1104058.tgz.asc
    Mail-SpamAssassin-rules-3.3.2-r1104058.tgz.md5
    Mail-SpamAssassin-rules-3.3.2-r1104058.tgz.sha1
    in ssh command:
    sa-update --install Mail-SpamAssassin-rules-3.3.2-r1104058.tgz

    this wll install the ruleset; when you build spamassassin again (./build spamassassin), no errors will turn up (that was the case on my server).

    hope this solves your issue too.

  5. #5
    Thanks for that useful information. I've updated the very bottom of the guide with the fix:
    http://help.directadmin.com/item.php?id=36

    We'll eventually incorporate this into custombuild and the spam.sh to bypass any 3rd party issues (unless they resolve it quickly)

    John

Similar Threads

  1. httpd service faild
    By empratoor in forum CentOS 6
    Replies: 4
    Last Post: 08-31-2012, 12:01 PM
  2. Failed to install
    By neorder in forum Installation / System Requirements
    Replies: 4
    Last Post: 02-02-2011, 01:10 AM
  3. service dovecot faild
    By hadi_gby in forum General Technical Discussion & Troubleshooting
    Replies: 1
    Last Post: 07-02-2010, 04:58 AM
  4. Spamassassin failed install
    By jpl in forum E-Mail
    Replies: 4
    Last Post: 08-25-2005, 05:24 AM
  5. Plugin Request: Mailscanner/ClamAV/Spamassassin
    By hci in forum Feedback & Feature Requests
    Replies: 2
    Last Post: 06-16-2004, 09:55 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •