Results 1 to 3 of 3

Thread: FreeBSD 7.x, PHP53 and Libtool

  1. #1
    Join Date
    Jun 2012
    Posts
    6

    FreeBSD 7.x, PHP53 and Libtool

    Hi,
    today I upgraded php version from 5.2.x to 5.3.26, so I issued:
    # cd /usr/local/directadmin/custombuild
    # ./build set php5_ver 5.3
    # ./build update
    # ./build clean
    # ./build php n
    [...]
    chmod 755 /usr/lib/apache/libphp5.so
    [activating module `php5' in /etc/httpd/conf/httpd.conf]
    Installing PHP CLI binary: /usr/local/bin/
    Installing PHP CLI man page: /usr/local/man/man1/
    Installing build environment: /usr/local/lib/php/build/
    Installing header files: /usr/local/include/php/
    Installing helper programs: /usr/local/bin/
    program: phpize
    program: php-config
    Installing man pages: /usr/local/man/man1/
    page: phpize.1
    page: php-config.1
    Installing PEAR environment: /usr/local/lib/php/
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php4/extensions/mssql.so' - Cannot open "/usr/local/lib/php4/extensions/mssql.so" in Unknown on line 0
    [PEAR] Archive_Tar - already installed: 1.3.11
    [PEAR] Console_Getopt - already installed: 1.3.1
    [PEAR] PEAR - already installed: 1.9.4
    Wrote PEAR system config file at: /usr/local/etc/pear.conf
    You may want to add: /usr/local/lib/php to your php.ini include_path
    [PEAR] Structures_Graph- already installed: 1.0.4
    [PEAR] XML_Util - already installed: 1.2.1
    /usr/local/directadmin/custombuild/php-5.3.26/build/shtool install -c ext/phar/phar.phar /usr/local/bin
    ln -s -f /usr/local/bin/phar.phar /usr/local/bin/phar
    Installing PDO headers: /usr/local/include/php/ext/pdo/
    PHP 5.3.26 Installed.
    ln: /bin/php: Read-only file system
    Rewriting all users httpd.conf files, please wait...
    Debug mode. Level 10

    dataskq: command: action=rewrite&value=httpd
    Restarting apache.
    Stopping httpd: [ FAILED ]
    Starting httpd: [ OK ]
    # php -v
    /usr/local/bin/php: error: `/usr/local/bin/.libs/php' does not exist
    This script is just a wrapper for php.
    See the libtool documentation for more information.
    root@jail1:/usr/local/directadmin/custombuild#

    Before this upgrade I had php52 and php4 so I moved all php4 directories to php4.old and remove /usr/lib/apache/libphp4.so.

    At this moment I have a correct libphp5.so but I haven't the 'right' php binary cli.

    Could you help me?

    Thanks,
    d.

  2. #2
    Hello,

    This is quite odd:
    Code:
    /usr/local/bin/php: error: `/usr/local/bin/.libs/php' does not exist
    This script is just a wrapper for php.
    try checking the php binary to see what it actually is:
    Code:
    ls -la /usr/local/bin/php
    ldd /usr/local/bin/php
    head -n 1 /usr/local/bin/php
    it should be a binary.. and the "head" command should produce garbled binary code if it's a binary.
    If it's a wrapper (which is strange), it might produce a script header, like #!/bin/sh, or something like that.. any text from the "head" command would mean it's not a binary.

    John

  3. #3
    Join Date
    Jul 2007
    Posts
    178
    'ln: /bin/php: Read-only file system'

    Are you running things in a jail or something?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •