Results 1 to 9 of 9

Thread: Upgrade php from 5.3 to 5.4

  1. #1
    Join Date
    Nov 2012
    Location
    Oldebroek, The Netherlands
    Posts
    31

    Upgrade php from 5.3 to 5.4

    Hi guys,

    With php 5.3 becoming an EOL version, I have decided to upgrade to 5.4. My question is: How can I best do this?
    My OS is CentOs 6.3.

  2. #2
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    6,943
    What is the CustomBuild version installed on the system?

    Code:
    /usr/local/directadmin/custombuild/build | grep Version | awk '{print $3}'
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  3. #3
    Join Date
    Nov 2012
    Location
    Oldebroek, The Netherlands
    Posts
    31
    Quote Originally Posted by smtalk View Post
    What is the CustomBuild version installed on the system?
    CustomBuild version is:
    1.2.36

  4. #4
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    6,943
    You should execute the following commands then to upgrade your PHP version:
    Code:
    cd /usr/local/directadmin/custombuild
    ./build update
    ./build set php5_ver 5.4
    ./build php n
    That's it
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  5. #5
    Join Date
    Nov 2012
    Location
    Oldebroek, The Netherlands
    Posts
    31
    Quote Originally Posted by smtalk View Post
    You should execute the following commands then to upgrade your PHP version:
    Code:
    cd /usr/local/directadmin/custombuild
    ./build update
    ./build set php5_ver 5.4
    ./build php n
    That's it
    Thanks! At the moment, mysql 5.5.27 has been installed, should I upgrade that to a higher version too? Or any other packet?

  6. #6
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    6,943
    MySQL 5.5 is okay. You would still have a chance to upgrade it to 5.6 in the future without any problems.
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

  7. #7
    Join Date
    Nov 2012
    Location
    Oldebroek, The Netherlands
    Posts
    31
    thanks smtalk! great help. now I first need my development and testserver upgraded to 5.4 so I can make sure all my software functions on 5.4. And then I'll try the steps you wrote abough. The upgrade is planned on may 11th at 1am so it'll be a while. But I'll let you know if it worked.

  8. #8
    Join Date
    Jul 2006
    Location
    Seattle, WA Area
    Posts
    75
    Hi smtalk, how about PHP 5.5? Can it be easily upgraded like 5.4?
    --
    Sam M.
    Net Step, Inc.

  9. #9
    Join Date
    Aug 2006
    Location
    LT, EU
    Posts
    6,943
    Yes, it can
    Martynas Bendorius
    MB Martynas IT. Professional server management company. Official DirectAdmin, CloudLinux, LiteSpeed and Comodo partners.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •