Results 1 to 6 of 6

Thread: domain.com/phpMyAdmin gives "No input file specified" after SuPHP+open_basedir

  1. #1
    Join Date
    May 2014
    Posts
    16

    domain.com/phpMyAdmin gives "No input file specified" after SuPHP+open_basedir

    Dear friends
    Our php mode is suphp and we realized that the open_basedir flah is not working with suphp
    So for avoiding user's to have access to other user's directories we were forced to implement the OLD WAY procedure of this article:
    http://help.directadmin.com/item.php?id=183


    So each user has a php.ini file under /home/$USER/ and in it we have defined the open_basedir as:
    open_basedir=/home/usernameOfourUser:/usr/local/etc/php5/cgi:/tmp

    Also for giving access to the webmail and phpmyadmin websites we defined the open_basedir path of the the main PHP.INI of server like this:

    Main php.ini ===> /usr/local/etc/php5/cgi/php.ini
    open_basedir=/usr/local/etc/php5/cgi:/tmp:/usr/local/directadmin/data:/var/www/html/



    Users can open webmail from:
    http://webmail.domain.com/
    But they can't open webmail from http://domain.com/roundcube ( No input file specified. )

    phpMyAdmin is only accessible from SERVERip/phpMyAdmin and we can't open the phpMyAdmin from
    domain.com/phpMyAdmin

    We can make it possible to open the phpMyAdmin from phpmyadmin.domain.com by changing dns template and virtual host (just like what we did for webmail.domain.com)

    But we want to know why the phpMyAdmin is accessible from
    serverip/phpMyAdmin

    but we are not able to open it using
    domain.com/phpMyAdmin ====> error message: ( No input file specified. )

  2. #2
    Join Date
    May 2014
    Posts
    16
    any help for this case?

  3. #3
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    13,069
    Hello,

    You should change

    Code:
    open_basedir=/home/usernameOfourUser:/usr/local/etc/php5/cgi:/tmp
    to

    Code:
    open_basedir=/home/usernameOfourUser:/usr/local/etc/php5/cgi:/tmp:/var/www/html/
    or redirect all requests from http://domain.com/roundcube to http://hostname/roundcube
    Regards, Alex G.

    - You can hire me on www.poralix.com to work on your server
    - Follow and like @Poralix on Facebook

  4. #4
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    13,069
    More secure would be to add this part into individual php.ini files:

    Code:
    [PATH=/var/www/html]
    open_basedir=/var/www/tmp/:/var/www/html/
    I've done a quick test and though it worked, there might be issues, so please test it more careful.
    Regards, Alex G.

    - You can hire me on www.poralix.com to work on your server
    - Follow and like @Poralix on Facebook

  5. #5
    Join Date
    Jun 2003
    Location
    California
    Posts
    26,122
    Quote Originally Posted by zEitEr View Post
    or redirect all requests from http://domain.com/roundcube to http://hostname/roundcube
    For what it's worth, I'd prefer to do it this way except to use https to take advantage of the shared server Certificate and use SSL login for Roundcube.

    Have you found a place to put this configuration so it will stick, and work with all new domains and through updates?

    If easy enough, I'd like to see this as a configurable DirectAdmin option, just as we now have for DirectAdmin control panel login.

    Any comments?

    Jeff
    +1 951 643-5345
    Third-Party DirectAdmin administration and support
    Dedicated Servers, Dedicated Reseller Accounts
    NoBaloney Internet Services div. Qnito Incorporated
    848 North Rainbow Blvd., Suite #3789
    Las Vegas, NV 89107-1103

  6. #6
    Join Date
    Apr 2005
    Location
    GMT +7.00
    Posts
    13,069
    Jeff,

    It has been discussed here many times already. It is already implemented in CB 2.0, so you may use auto redirect to hostname.
    Regards, Alex G.

    - You can hire me on www.poralix.com to work on your server
    - Follow and like @Poralix on Facebook

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •